What ports does UCP Really use

All Ports at default and all ports open:

But when I connect with UCP to port 81 I get this:

<img src="/uploads/default/original/2X/8/81dffb4f77493ffa5492bedc5f901cc0f84268fa.png"width=“690” height=“66”>

But if I sneak a rule in to allow all TCP to that IP I get this:

Does anybody know what other port I need to open or am I going to have to do some packet captures?

Apparently a too-aggressive SonicWALL - Moved it out to a Public IP with the Sangoma firewall and everything is good.

Ports 8001 and 8003 also need to be open.

The red bar indicates an issue connecting to the Node server. In Settings, Advanced Settings, you can see which ports Node is using. The default ports are as @kolpinkb says.


We work very hard at keeping the wiki updated. For example we have this wiki on every port on the pbx for every possible service.


1 Like

Nice - bookmarked that page - Does UCP need port 8001 - It’s not on the Wiki page?

Also, port 5061 (TLS for SIP) and 5161 (TLS for PJSIP) should be marked as TCP in the page.

8001 is not used since the 8001 is http and 8003 is https for webrtc and webrtc now requires SSL so 8001 is basically useless.

Yeah, I am finally getting UCP and WebRTC to work properly - 8003 is what was killing me with the Node error - and I didn’t know about 8089 - my WebRTC just never dialed - now EVERYTHING is working! This is such a nice feature!