What is the problem of arrival cpu 100%

Hello everyone
Whats the problem in astersik when the CPU go to 100% temporarily for a few seconds, The result in Naturally mode:
PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
2543 asterisk 20 0 5336564 864908 20932 S 12.3 10.8 2703:26 asterisk
14336 asterisk 20 0 664288 45220 23172 S 7.0 0.6 0:09.47 httpd
14323 asterisk 20 0 664692 49348 27032 S 5.0 0.6 0:03.55 httpd
1375 mysql 20 0 2352292 292236 9788 S 3.0 3.6 848:42.00 mysqld
1400 mongodb 20 0 482832 39076 4636 S 0.7 0.5 253:51.05 mongod
5092 asterisk 20 0 1084756 47576 14364 S 0.7 0.6 1:27.42 node /var/www/h
32128 asterisk 20 0 422376 43088 10976 S 0.7 0.5 0:38.58 php
738 root 20 0 21672 1104 972 S 0.3 0.0 4:14.70 irqbalance
2165 root 20 0 162104 2296 1580 R 0.3 0.0 0:08.28 top
9590 root 20 0 0 0 0 S 0.3 0.0 0:20.97 kworker/u16:1

When the CPU go to 100% all employees suffer from a problem in interrupting calls and returning to normal in the same line phone.
Note: Knowing that the server was working normally two months ago and there are no problems but the problem Appeared two days ago
the result

Is there urgent assistance?

Is this Asterisk now, or FreePBX?

My server below
Capture1111

Any help please?

There were some reports a month or two ago. Is your PBX up to date?

If not, run:

yum update

Then

fwconsole ma upgradeall

Then

fwconsole r

And reboot your PBX from the GUI.

Thank you for your replay,
I will today checking update after when my work time finish, After that i will update the server and check if the issue back again i will replay to you here.
Best Regards

After Upgrade and applied the command
yum update
fwconsole ma upgradeall
fwconsole r
And after that i rebooted the server, When the server up all service worked approximately 5 second as fine after that the server can’t work and not response, If “asterisk -vvvvvr” not response after 5 second when the server start, All extension was disconnected, Since that the upgrade version 14.0.11
Whats the problem and how can solve the problem??
In this time i back to snipshot because i can’t wait.
Any help?

Which version of Asterisk were you on after doing updates?

FreePBX 14.0.5.25

That’s Framework, not Asterisk.

Do you know what version of Asterisk it was after updating?

And which version of Asterisk are you using now?

The result of version

[[email protected] ~]# asterisk -r
Asterisk 15.7.2, Copyright © 1999 - 2016, Digium, Inc. and others.
Created by Mark Spencer [email protected]
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘core show license’ for details.

AsteriskNOW*CLI> core show version
Asterisk 15.5.0 built by mockbuild @ jenkins7 on a x86_64 running Linux on 2018-07-25 22:19:48 UTC

Note:
The result I’m used now in live mode.

Ok. Is it still reaching 100% CPU?

In this time I have a big new problem , The server and service not working as fine when reboot the server after starting 5 min. the server not working between calling employees, If you can see my post below:

But you said that you rolled back because you couldn’t wait.

So do you currently have this issue?

Yes, I have the issue
And to assume that the problem CPU has not been resolved but I returned the oldest version and a new problem occurred to me during my reaction to the previous version and talk when I do the very operation of the server, I have already explained in my post below

Dear Mr. PitzKey,
I need to tell you about the last update in my case we have,
We restore the backup file (The old one) since 30 days, And update the server to last one (Astersik freepbx and framework) equal:
Current PBX Version:14.0.11
Current System Version:12.7.5-1902-3.sng7
Current Asterisk Version: 15.5.0
We rebooted many times to tested the server and after that the server stable and worked as fine without any issues tell now,
The H.W system information:
6 CPU virtual core
12 Ram
50 HDD
The system utilization

[[email protected] ~]# free -tm
total >>> used >>> free >>> shared >>> buff/cache >>> available
Mem: 11853 >>> 1049 >>> 9792 >>> 64 >>> 1011 >>> 10372
Swap: 5119 >>> 0 >>> 5119
Total: 16973 >>> 1049 >>> 14912

CPU was used 15% at the max.
And i will show you about the result of (top)

I will monitor the server if any issue i will update you,
Best Regards.

In this time i have some of high latency when i pinged from my pc to server, And the high latency that
Ascension has an effect on the server in the case if communication between two extensions is observed
There is a loss in the call while talking to two devices(extensions), what is the reason or where is likely the reason,
I will show you below:


Any help?

Be aware that ping uses icmp which is a very different and unrelated protocol than SIP uses (tcp/udp/tls/wss et al.) .

ICMP are the first packets dropped at the router when needed. A better metric is the “status” column shown by:-

rasterisk -x ‘sip show peers’

which is indicative of the latest SIP “roundtrip” between asterisk and the endpoint.

Dear Mr.Dicko,
When i try to check the command “rasterisk -x”, And the result
[[email protected] ~]# rasterisk -x
rasterisk: option requires an argument – ‘x’
How can apply the command !
At this time happens to me as well as the staff, while talking to the conversation occur in the talk between the two communications, and I did not notice anything in the ssh debugging " asterisk -vvvr"

By your estimation of the occurrence of such a situation, which is during the communication between the two parties continues to talk without problems but at some time occur cuts in the talk and this causes inconvenience to employees and after a few seconds of the connection is returned without any problems and this case frequent. How can i solve the issue?