What could have happened to the GUI and SSH?

Was browsing around the web GUI just fine. Saw the update to 12.0. Went to link/module (new to PBX) and just read the instructions. Didn’t click on anything! Co-worker and myself wanted to ssh into the asterisk box, tried twice (bombed the PW both times) and then nothing, the ssh session froze. Closed it out and opened it back up and now it cannot connect to host, and the GUI just displays ‘webpage cannot display’.

What on earth could we have done?

Your intrusion detection kicked in and blocked your IP based on failed logins. Try from another IP address

1 Like

Man, thank you Tony!. Like I said, new to this and you saved my worries! I just went ahead and checked again, had to get a few episodes of Daredevil on Netflix out of the way, and it worked right away. Not trying the SSH until I know the password. I don’t mean to ask you to go above and beyond, but how exactly does that intrusion prevention work? I looked up an article, I stress ‘an’ as in one, and I don’t see it in the PBX section or may be missing it? Is that CLI controlled only? A Barney style explanation would work!

1 Like

At your cli, type the following :
man fail2ban-client


Go into the Sysadmin module and under intrusion detection you can set thresholds and whilelist IP’s or subnets