Weird One Way Audio

Good day to all of you.

I’m really banging my head already cause I can’t seem to figure out the problem with one of our freepbx server.

My server is located within NAT and one of the users connect through it using PAP2T with VPN connection to the network. So it’s still inside NAT. Everytime I make a call, it’s always a oneway audio, the one I’m calling to can hear me but I can’t hear the other side. It’s not the PAP2T cause when I change server with the same settings, it works. There’s just something with this server that’s breaking everything. It was working well last week, but all of a sudden broke down. I have FPBX-2.9.0( this problematic server. I compared the settings to my working one and I can’t see anything different.

Thank you in advance for your support.

I finally fixed this one after several hours of Banging my head. If you have a permanent VPN connection between your client and server, you need to define the vpn remote subnet in your conf. Just posting this one to help others.

One thing I can’t solve is why suddenly it was checking the subnets. Before it wasn’t doing that. My other box didn’t have these things defined and it works. What’s with this box?

Any comments and answers are very much appreciated.

If you have NAT turned on and an externip defined you must declare all traffic to be excluded from NAT processing with localnet statements per netblock.

Does this make sense?

It does make sense but I had NAT and externip defined from the start. It wasn’t doing that since last week. I have another box which has the same set up but it didn’t need such added configuration. The only thing that bugs me is that why it became strict with such config just last week.

Thanks for the reply SkyhingOH.

I can’t imaging why the behavior changed. These variables have been in Asterisk and have been required since version 1.2.

If you don’t have a localnet setting for every network to be excluded from NAT, Asterisk will rewrite the invite message using the externip variable.

I’m really not sure what happened to this server. I’ll try to investigate more and check what happened. Can a module upgrade do it?


No, a module update would not have a change on Asterisk behavior.

It could have caught a syntax error in a SIP global. Did you install the sip settings module?

Yes I have most of the modules installed including the SIP Settings module. So if I have an externip configured I need to configure the local subnets as well. What if I have this configured and in the SIP settings I configured that NAT=no, it won’t make use of the NAT settings right? So it wouldn’t matter if I configure and externip since I set NAT to no?

Thanks for your reply SkykingOH.

I have two nics on my pbx, one is one subnet the other in another for the phones only. You need to define BOTH networks in the Asterisk sip settings - localnet (local networks)! This thread saved me :slight_smile: Just throwing this out there for others that stumble across. I was getting one way audio and network errors.

One possible explanation for this (and I’m not saying that it is THE explanation) is how FreePBX handles the Asterisk SIP Settings page. On a fresh install, the Asterisk SIP Settings page will show various settings that are NOT actually programmed into the relevant .conf files. FreePBX doesn’t actually program those settings until you make a change, click submit, and do an orange bar reload. So, on a fresh install, if the Asterisk SIP Settings showed NAT=yes (or NAT=no) or whatever, that settings may NOT actually have been in the relevant .conf file.