Weird backup issue on FreePBX 15


Just upgraded my FreePBX from 14 to 15 and backup is playing up, I tried to remove some modules from backup to see if it went through to no avail (in this case userman is not selected for backup but I believe it’s a dependency). Been trying for the last 3 hours with no luck.
This is what I am getting:

Working with userman module
Exporting Databases from userman

In Database.class.php line 212:

  [PDOException (42000)]
  SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1

Exception trace:
 () at /var/www/html/admin/libraries/BMO/Database.class.php:212
 PDO->query() at n/a:n/a
 call_user_func_array() at /var/www/html/admin/libraries/BMO/Database.class.php:212
 FreePBX\Database->query() at /var/www/html/admin/modules/backup/BackupBase.php:87
 FreePBX\modules\Backup\BackupBase->dumpDBTables() at /var/www/html/admin/modules/backup/BackupBase.php:132
 FreePBX\modules\Backup\BackupBase->dumpTables() at /var/www/html/admin/modules/userman/Backup.php:6
 FreePBX\modules\Userman\Backup->runBackup() at /var/www/html/admin/modules/backup/Handlers/Backup/Common.php:99
 FreePBX\modules\Backup\Handlers\Backup\Common->processModule() at /var/www/html/admin/modules/backup/Handlers/Backup/Multiple.php:99
 FreePBX\modules\Backup\Handlers\Backup\Multiple->process() at /var/www/html/admin/modules/backup/Console/Backup.class.php:179
 FreePBX\Console\Command\Backup->execute() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Command/Command.php:255
 Symfony\Component\Console\Command\Command->run() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:960
 Symfony\Component\Console\Application->doRunCommand() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:255
 Symfony\Component\Console\Application->doRun() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:148
 Symfony\Component\Console\Application->run() at /var/lib/asterisk/bin/fwconsole:163

backup [--backup BACKUP] [--externbackup EXTERNBACKUP] [--dumpextern DUMPEXTERN] [--transaction TRANSACTION] [--list] [--warmspare] [--implemented] [--filestore FILESTORE] [--restore RESTORE] [--restorelegacycdr] [--modules MODULES] [--restoresingle RESTORESINGLE] [--backupsingle BACKUPSINGLE] [--singlesaveto SINGLESAVETO] [--b64import B64IMPORT] [--fallback]

Also tried update userman and the backup module to the latest edge to no avail. MySQL is running and it’s accessible.
Any idea what could be causing this?

Hi @xhemp Could you please raise bug in and send me ([email protected]) your backup file so we can try to reproduce issue in-house. thanks a lot.

1 Like

Just to close this, the reason I was seeing that error was that I had MySQL instead of MariaDB, going to MariaDB resolved the problem.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.