WEBRTC phone register but unavailable

HI Everybody,

after updating our System (10.13.66-11) with the latest Status Patches, WebRTC Phones can logon, can make call’s but show as unregistered in CLI and therefore can’t be called.
I have tried re configuring the Firewall, stopped the Firewall etc. but its not working.
Everything was working perfectly before the update.

Does anybody has a similar experience or and idea how to solve.

thanks a lot for any help already in advance.

You need to use webrtc version 13.0.25 or later. 13.0.27 is the latest and comes from the Edge Track.

Hi billsimon,

thanks a lot for your reply.
My WebRTC Version was 13.0.26, the latest stable one but I have upgraded to 13.0.27 from Egde Track, as you suggested. Thanks for that advice, I was not aware of the Edge track yet, thanks.
But still the same issue unfortunately. Still it logs on, I can make call, but it shows as unregistered, if I make “sip show peers” in CLI.
After I tried to simply downgrade and with the Version 13.0.20 its working again.

So I don’t know, whether there is anything else I could do now, maybe waiting for a new stable version and try again.
Since it works after downgrading this single Module, I assume there is nothing wrong in other Modules of the System.

If you or anybody has any advice for me, I would be happy to solve the issue in a different way then downgrading to an older Version.

thanks a lot for your help.

Dear guys, sorry, but I couldn’t up WebRTC yet. In last updates certificate manager module and https setup in Sysadmin module are changed. How do you configure them?

Hi psdk,

I have simply created a self signed certificate in the certificate manager and use this in the User Management Module to activate WebRTC and its working very well.

Maybe I should mention, that we are using WebRTC only either internal, or via VPN to the Office or in remote Offices, where we setup Firewall Rules, that the our Firewall is accepting those Traffic only from trusted IP’s.
We are not using STUN or ICE or something like this …
I decided to do so, as our user are very difficult to teach to use complex and secured Passwords, so opening this i considered as to risky :slight_smile:

Hope I could be helpful.

Thanks NUB,I did this too, but when I want connect via https to UCP, Firefox or Chrome doesn’t permit.
Do you install Node UCP too?

Hi psdk, yes, I have installed the UCP Node Server Module as well. But as I remember it’s setup by default.
The last FreePBX setup I did right from the ISO and I believe it was in.
I never really had a Problem with WebRTC, except this days with the latest update.
You need a certificate, I use a self signed certificate and enable it in the User Management Module.
It always worked for me and I have a couple of FreePBX System running with this.
Hope it can work for you too.

Thank you dear. I use the last version, but unfortunately WebRTC phone in UCP doesn’t work, and when I dial a number, nothing happens.
Anyway thanks for hints.

Only some questions that may help me:
1- do you make self-signed for localhost or your server IP?
2- your users connect via HTTPs to UCP or HTTP?
3- your users use Firefox or Chrome?

I made a self-signed certification for localhost, but now I can only access to UCP via https from Firefox and Chrome doesn’t permit and gives certification error access.
although, when users access to UCP via HTTPS with Firefox, they receive:

Unable to connect to the UCP Node Server because: ‘Error: xhr poll error’

  1. I issued to my internal IP
  2. I connect on http (only sharing this inside the Network or via VPN)
  3. I use Firefox, but booth are working

If you want to investigate it, post the verbose Asterisk log and SIP debugs corresponding to starting the webrtc phone.

That error means the node isn’t running. Try doing an fwconsole restart to see if that starts the node back up.

thanks but node is running and I’m using XMPP too. this happens on HTTPS connection.

I’m running WebRTC on a system that has an SSL cert on it. I have no issues connecting to the UCP via HTTPS.

Have you properly configured the certificates on your system? Did you use System Admin to set the HTTPS settings for the GUI, etc?

yes I did all of this. I can only make a call from Firefox on http.
Are you using self-signed? your system has latest updates?

No, I am not using self-signed. Yes, my system has the latest updates for all the modules. But I also have another system that is using self-signed and I do not get that error in my browsers. I also have the cert installed as well to avoid any errors.

Perhaps that’s the issue. But as far as I can see I’m able to do HTTPS in the UCP without any issues.

Have you even tried an fwconsole restart just to make sure?

Also what mode on you in? Extensions or User/Device. The WebRTC will only accept calls when you ring the extension if it’s in User/Device mode otherwise you have to call it directly via 99. You may have to edit and then save the 99 user for it to have all the proper settings.

yes many times my friend.
you are ok with both Chrome and Firefox?

Yes, to both. I’m not having any issues with it. When I do get that error (and very rarely), I just do fwconsole restart and it goes away.

I did this again now, but no changes.
Did you any settings in Advanced settings for node-js?