Is it possible to configure the WebRTC phone (and dependent applications) to use secure websocket connections?

The UCP and admin interface are enforcing strong HTTPS and Firefox isn’t allowing connections to the unencrypted websocket connection.

Hey same is the problem i am facing,i am getting the error as below

WebSocket connection to ‘wss://x.x.x.x:8088/wss’ failed: Error in connection establishment: net::ERR_SSL_PROTOCOL_ERROR

I have tried to change the code in ucp phone. I have just changed the suffix and server address add one s to use wss. it gives the above error.

If i am checking the asterisk cli, i can see that asterisk is bind to ws,not wss. It was configure used ssl with libsrtp. Os i am using is debian 64 bit.

Any help would be much appreciated.

Transport for user is All-Ws Primary. But if i see in the sip_additional.conf. I can see that its only giving me ws. So what i did is i edited the transport,add wss to the transport. Without using amportal restart. I connected to asterisk cli,used sip reload. and after sip reload.Tried same error.

Even i checked the sip_additional.conf has the transports and settings i made.

Please help asap. I would appreciate your help much.


Warm Wishes

Did you get anywhere with this? I setup an SSL cert and made the UCP use it hoping to avoid prompting me everytime to allow mic access. Only problem is when using the UCP in HTTPS the WebRTC phone does not work. I dial a number hit Call and it doesn’t do anything. Viewing it in HTTP it still works…