Web UI JS not working


(United States) #1

I am using freepbx 14 which has been working perfect for over a year now, and the system is still working fine, but I can not login to the admin panel. I get the landing screen, but when I click the administration link which should open a login dialog I get nothing. I looked at the page source and manually opened the login form but it does not function ether. It seems like non of the JS on the page works. There are 2 errors in the console that also suggest there is no JS but no 404 errors and all scripts are loaded with the page.

I have restarted the server and tried reloading from the FWconsole. No change. There’s no unusual activity that I can see. I was getting close to the storage limit on the server, which I received notifications relentlessly, which I usually just go in an delete the oldest 6 months of recordings but that was when I found I could not get into the interface. I deleted the files but the notifications start with about 32GB of free space left and there was still 30+ when I cleaned out the old recordings. So its not a space issue.

Im not sure what to check from here, any thoughts are greatly appreciated.


(Richard Smith) #2

Have you tested with another browser or clearing the Cache? I sometimes find that works.


(United States) #3

Sorry, forgot to mention, Every modern browser, 3 different computers on 2 networks and one Windows VM on the same host as the freepbx server. All do exactly the same thing.


(Itzik) #4

Tried updating the server?

fwconsole ma upgradeall
fwconsole chown
fwconsole reload
yum clean all
yum update -y

(TheJames) #5

Google Chrome

Console Logs in Chrome:

In Google Chrome, the Console Logs are available as a part of Chrome Dev Tools.

To open the dedicated Console panel, either:

  • Press Ctrl+Shift+J (Windows / Linux) or Cmd+Opt+J (Mac).

You can also access this Console panel from the Chrome Menu :

  • Locate and Click the “Three dots Menu bar” on the top right of your chrome browser.
  • Go to More tools >> Developer Tools.
  • Switch to Console Tab.

In the Console Tab, you can find the current error messages (Displayed in Red) along with other console level information such as warnings and info.

Mozilla FireFox

Console logs in FireFox

In Mozilla FireFox, the Console Logs are available as a part of FireFox developer tools.

To open the Web Console:

  • either select “Web Console” from the Web Developer submenu in the Firefox Menu (or Tools menu if you display the menu bar or are on Mac OS X)
  • or press the Ctrl+Shift+K (Command+Option+K on OS X) keyboard shortcut.

Safari

In Safari Browser, console and network logs are available as a part of “Develop Menu”. By default, these options are disabled. To enable “Develop Menu”,

  • Launch “Safari”.
  • Go to Safari >> Preferences >> Advanced (From the header).
  • Enable “Show Develop Menu in Menu Bar”.

Console logs in Safari:

Post enabling “Develop Menu”, go to the desired webpage and click Develop >> Show Javascript Console.


(United States) #6
Uncaught ReferenceError: moment is not defined
    at config.php:87
Uncaught TypeError: $.urlParam is not a function
    at config.php:87

Are the only two entries in the console logs, no function I can find anywhere in the source references the ID of the form element or the form submission values. It seems like a whole JS file is missing.

I will try upgrading and updating permissions and report back.


(United States) #7

Ran all the updates suggested, no change. looking through the sources I found this file was loaded but the file is blank. It does exist, no 404, but nothing inside.

https://******.com/admin/assets/js/pbxlib_a1fe8fb5804364f4aa5b3718e2fef39bcbb9c180.js?load_version=14.0.16.11

I did try loading the file without the version but still blank. This is on the same line right before the code the 2 errors in the console references.


(United States) #8

Found the issue, the suspect JS file somehow creates an issue. Deleting it and refreshing the page worked.

rm -rf /var/www/html/admin/assets/js/pbxlib_*

Its a known issue:
https://issues.freepbx.org/browse/FREEPBX-22239


(system) closed #9

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.