Web GUI Stopped Working


(Ben Hoover) #1

I had an install of FreePBX that was working fine. I came back after the weekend and now the web GUI is no longer working properly. I can log into it and the header and footers display along with the dropdowns but nothing else displays. For example, when i click on the ‘Dashboard’ link, it appears that it is loading the page but nothing displays. The same goes for all of the other links in the dropdown menus. The only error I see is ni the weserver logs: AH01630: client denied by server configuration: /var/www/html/admin/index.html


(BGM) #2

If you login to the ssh console, you can run this:

service httpd restart

And that fixes it for me. I don’t know why it stops, though.


(Ben Hoover) #3

Tried that and tried rebooting the server altogether and neither had any effect.


(BGM) #4

Try clearing the cache in your browser, or try a different browser - and make sure your adblocker is disabled. Make sure it isn’t the browser, you know.

Can you log into the UCP?

Ah, maybe take a look at this:


(Ben Hoover) #5

Yeah I tried multiple browsers on multiple different machines. Disabled selinux and firewall, all to no avail. Like I said this was working a few days ago and nobody touched the server between then and now but something appears to have gone wrong with the webserver.


(Dave Burgess) #6

Have you looked in the browser logs?

/var/log/httpd/error*
/var/log/httpd/access*

Start with error log, since (one would hope) that’s where the errors should be. :slight_smile:


(Ben Hoover) #7

Yup, the only error is:

AH01630: client denied by server configuration: /var/www/html/admin/index.html


(Dave Burgess) #8

OK - this is actually an “Apache” configuration problem.

I don’t remember exactly where the htaccess file for the admin directory lives (and I’d rather not post it - why make it easier for the script-kiddies) but you do one of two things:

  1. Go into the Apache config files and comment out the htaccess directive. This will turn off the password protection on the index page. This opens you machine to what will look like the monsters from “The Matrix” descending on your server, so get it, fix it, and get out.

  2. Go into the htaccess file and re-add your “admin” using the “htpasswd” program. Restart the web server and you should be good to go for at least a little bit.

Either way, I think you’re going to need to location of the password file.


(Lorne Gaetz) #9

I suspect the “Client denied by server config” errors are a red herring and not related to the issue. There are fixes in edge for these:

https://issues.freepbx.org/browse/FREEPBX-20496
https://issues.freepbx.org/browse/FREEPBX-20473


(BGM) #10

Did you make any system updates or module updates? I had an issue once where if I upgraded the UCP to a certain version, I could not commit updates to Device Mangement. A later update to the module fixed that, though.

There is a place in System Admin > Intrusion Detection where an ip can be blocked. Maybe there’s a log for that where you can check to see if your ip is being blocked? That page has a whitelist, too.

Are you able to ssh into the linux console?


(Ben Hoover) #11

I found the password file. For number 1, where is the htaccess directive in the Apache config file?

I tried re-adding the admin user using htpasswd but that totally broke the webserver and the pages don’t load at all.


(Ben Hoover) #12

I figured this out on accident but the root cause is that the presence of the SIPStation module causes the GUI to break. I installed a fresh version of the FreePBX distro and the GUI was broken right off the bat. I removed the SIPStation module and voila! Everything is back to working. Any ideas what would be causing this? I was planning on using a SIPStation account to do some testing.


Freepbx 14 wont display GUI login page
(BGM) #13

Well! At least you figured out something! That’s always gratifying. I never use SIPStation myself. One of the other users will have to help you with that one. But you need to keep posting here every few days or the thread will close automatically. I’ve had so many threads close on this forum without any responses (and then they come up in the searches, making the forum lead to a lot of dead ends and reducing the effectiveness of finding answers in this place).


(system) closed #14

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.