Warning: Cannot connect to online repository(s) (http://mirror1.freepbx.org,http://mirror2.freepbx.org). Online modules are not available

Is anyone else getting this message at the moment when trying to upgrade modules, or is it just me?

“Warning: Cannot connect to online repository(s) (http://mirror1.freepbx.org,http://mirror2.freepbx.org). Online modules are not available.”



Down since 0100 eastern (US) time.

Try using the https repo, that one is historically more stable. There is an alternative repo that can be found on my twitter but I won’t link here because well…

I have noticed I am unable to connect to mirro1.freepbx.org and mirror2.freepbx.org
I cannot find any service status pages regarding them or anything in the blogs/community.
I am able to ping both mirrors on 3 different connections (and separate providers) but I cannot reach the actual pages to check for updates etc.

First noticed 11am GMT today.

Hi James,

Thanks for responding. I’m certainly happy to give https: that a try… can you point me to where in the GUI I can set that up? Or is that something I need to do with a fwconsole incantation?


You can change using

fwconsole setting MODULE_REPO https://mirror.freepbx.org

mirror1 is back up again

1 Like


1 Like

Hmmm… I tried again without making that change as you reported that mirror1 was back… but no luck - same warning as before.

I then tried the fwconsole command above (literally, ie mirror, not mirror1 or mirror2)… and and still no luck… same warning but for https://mirror.freepbx.org instead.

All repos are responding for me. Are you able to ping them?

All is good now… and I was able to ping them throughout.



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.