Warning: Cannot connect to online repository (mirror.freepbx.org). Online modules are not available

I Can get updates with asterisk fine and i can ping that server and it resolves the right ip address… anyone know why this is?

what type of firewall are you using?

Philippe Lindheimer - FreePBX Project Lead
http//freepbx.org - IRC #freepbx

sonicwall pro 1260

the problem is in your firewall. Uncheck: uncheck the “Enforce Content Filtering Service” on the LAN zone (or something like that).

Philippe Lindheimer - FreePBX Project Lead
http//freepbx.org - IRC #freepbx

I had the same problem tonight though I have a Sonicwall TZ170 running the Enhanced OS.

The solution is described here:

http://www.radiotope.com/writing/?p=95

In short, the CFS engine is running no matter if you have a license for it or not and the firewall is dropping only the HTTP GET packet (though the earlier SYN/SYN-ACK packets go through fine). You have to manually disable the CFS engine via the undocumented http://your.ip.address/diag.html URL after logging in.

My guess is that the short HTTP GET packet causes the CFS engine to drop the packet. Wireshark showed only

HTTP GET /modules-2.3.xml HTTP/1.0\r\n

with no other accompanying parameters as you typically find when a true browser does an HTTP GET (e.g. Host:, User-Agent:, Accept:, Keep-Alive:, Connection:, Referer:, Cookie:, Authorization:, etc. etc.) followed by TCP retransmissions (since no ACK was ever received back from freepbx.org). A wget of the the URL worked just fine from the same IP address so I’m not sure what else the Sonicwall triggers on, but I was stumped (and no mention of the “…examining stream for host header” message on either sonicwall.com or mysonicwall.com that I could find, sigh).

If FreePBX faked some of the additional fields when issuing the GET I bet the packet would pass through the Sonicwall just fine. I could see a security-paranoid web proxy do the same thing too (I wonder how you could force Squid to do this?).

Nathan

I have the same problem yestarday, at a point was worked and downloaded some modules, but after stoped again. Maybe is a problem of the mirror site?

I am having the same problem but I am not using a firewall, so that would tend to point to the mirror site having problems. On top of that, Saturday & Sunday I was unable to access this site. It just did not respond.

C

i had the same problem… but it was due to incorrectly setup of my dns and hosts parameters in my linux configuration… after i fixed that - it is all smooth sailing from here…

What exactly was the incorrect setup of your dns & hosts? I have two systems, 1 Elastix & 1 Trixbox 2.2 which are both reacting the same way.

C

Had the same symptoms with the the checking of online updates for modules failing. I disabled content filtering on the Sonicwall and it all worked properly after that.

Many thanks to this post, I would never have thought of that.

Regards
Rich

Don’t forget to make sure that the php.ini used by your webserver has “allow_url_fopen = On” defined. Many distributions are defaulting this to Off for security reasons.

Hello,

I have made a fresh install with freepbx. I cannot access online respiratory. I get Cannot connect to online repository (mirror.freepbx.org). Online modules are not available. I have check my DNS setting and everything seems ok. I was able to download this:

[[email protected] opt]# wget http://mirror.freepbx.org/freepbx-2.3.1.tar.gz
–15:28:19-- http://mirror.freepbx.org/freepbx-2.3.1.tar.gz
Resolving mirror.freepbx.org… 69.41.162.148
Connecting to mirror.freepbx.org|69.41.162.148|:80… connected.
HTTP request sent, awaiting response… 302 Found
Location: http://superb-east.dl.sourceforge.net/sourceforge/amportal/freepbx-2.3.1.tar.gz [following]
–15:28:20-- http://superb-east.dl.sourceforge.net/sourceforge/amportal/freepbx-2.3.1.tar.gz
Resolving superb-east.dl.sourceforge.net… 209.160.66.130
Connecting to superb-east.dl.sourceforge.net|209.160.66.130|:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 4308674 (4.1M) [application/x-gzip]
Saving to: `freepbx-2.3.1.tar.gz.2’

100%[================================================>] 4,308,674 822K/s in 5.4s

15:28:25 (783 KB/s) - `freepbx-2.3.1.tar.gz.2’ saved [4308674/4308674]

Any help will be appreciated.

Roman

Hello Roman,

I am responding in the other thread…

http://freepbx.org/forum/online-update-problem#comment-9221

After reading all of the posts and following all of the good advice, I cannot seem to resolve a problem I am having with one of my servers. Exactly 5 weeks, 6 days, 5 hours, 15 minutes ago I received the last communication with the freepbx mirrors from this server via FreePBX. wget http://mirror.freepbx.org/modules-2.4.xml works fine. Ping works. Dig works. This server is a TB 2.0.0 distro with FPBX 2.4.0.0. I am attempting to upgrade FreePBX for the updated que module.

http://mirror.freepbx.org/modules/release/2.7/

all the modules are available here, download them and upload them manually from your computer.
No need of Online repository