Wake up Call

When I put in a manual wakeup call this error shows up and will not add the call.

undefined index: application
File:/var/www/html/admin/modules/hotelwakeup/Hotelwakeup.class.php:885

When the *68 code is used it will take the setup but when it goes to call back these errors show up in the logs and won’t process the call.

15672[2022-11-16 13:23:00] WARNING[3360] pbx_spool.c: At least one of app or extension must be specified, along with tech and dest in file /var/spool/asterisk/outgoing/wuc.1668622980.ext.8101.call

15673[2022-11-16 13:23:00] WARNING[3360] pbx_spool.c: Invalid file contents in /var/spool/asterisk/outgoing/wuc.1668622980.ext.8101.call, deleting

Everything else inside freepbx works. I can make and receive calls. IVR works. Internal extension calling works. ETC…

Using Asterisk 19 and Freepbx 16

Looks like all I needed to do was fully remove the module and reinstall it.

I’m leaving this here for anyone who has this problem. When I searched all I could find was DAHDI problems from over 10 years ago.

there is still an issue yet i have more details to help debug it.
reinstall the wakeup call module and it will work.
go to the wakeup call settings page and make any change and save it and it no longer works with the same errors as tigger1197 report. please fit.

I had to use the remove option, not just the force download and install. Then apply settings then download the module. It worked properly after that.

Tigger
i tried both uninstall, remove and force download and still it works fine until i change and save setting on the wakeup call setting page. the only 2 fields i am changing are length to 3 and extensions. as soon as i do that it give the same errors again until i remove and install.
have you changed any of the setting on the setting page. if so which fields?

bill a

I didn’t change any of the settings.

Yeah that is the bug. as soon as you change and save settings the bug comes back. the settings are under the setting menu at the top, a different page. they allow you to assign certain extensions to be able to program a wakeup call for any extension via the phone (aka not web gui)

A new version is coming soon fixing this issue.
It looks the issue comes from when a system has been migrated from 15.

thanks!! please post when it is released and i will test.

It looks there is a new version from EDGE repo.
Please : fwconsole ma downloadinstall hotelwakeup --edge