W7XX Series Installation with EHS30

I have a Sangoma S700 (firmware with EXP100

Recently purchased an EHS30 adapter and followed the wiki to set it up, https://wiki.freepbx.org/display/PHON/Plantronics+Headset+Installation

My headset appears to work and I wanted to upgrade my EHS firmware following the wiki https://wiki.freepbx.org/display/PHON/How+to+Update+EHS+Firmware

Problem is, pressing the EHS button, Ok, then start the Update EHS window says

EHS Version:N/A please disconnect EHS, then reconnect it.

I’ve tried disconnecting/reconnecting and even rebooting the phone and starting over but it never finds EHS version and won’t upgrade.

So, even though my headset works and I can dial out and receive calls the EHS doesn’t register?

Anyone know if the green light on the EHS30 adapter is supposed to illuminate because mine does not.

Has anyone set this up and updated the firmware?


I’ve had multiple problems with this as well. I also have an EHS adapter here that doesn’t light up. When I go into the web interface for the phone it also doesn’t show up there. I doubt I will be able to warranty this EHS adapter since it was two way taped to the back of the phone and the serial number came off when I removed it as it was a paper sticker…

The others that I’ve run into issues with I was able to resolve by unplugging them and re-plugging them in and making sure that the cables are fully inserted. The 6 pin cable was actually clipped in but needed to get pushed in a bit more for it to work.

If you see the EHS version from the phone’s web interface for both Version on phone and EHS Module Version then it will work____

I’m really disappointed with the quality of these Sangoma products. We’ve had 3 EHS adapters which are bad out of the box (Don’t light up/Don’t Work) and I’m finding the actual phones to be much lower quality than our Aastra, or Polycom.

Guys the LED on the EHS does not light up. It flickers on and off when you answer and hangup a call.

As far as bad EHS adapters. We had a handful of people having issues that the plug was not making good contact inside the jack. We spent alot of time with the users on this and it turned out they were plugging in the RJ9 cord into the RJ11 slot which was bending down the outer 2 metal contacts on the RJ11 jack so when they plugged in the RJ11 cord instead of the mistaken RJ9 cord it would still not make contact. I know it sounds silly but we had 6 plus customers all having the same issue and they all confirmed they had used the wrong cord the first time which damages those 2 outer pins.

I can confirm what Tony C Lewis has stated. I too thought I knew how to hook up given how the old Avaya phone. I assumed I just plugged the EHS30 into the headset port of the phone and I bent my PINs, but was able to bend back with a small screw driver and now all is well.

Be sure to check out the WIKI first - https://wiki_dot_freepbx_dot_org/display/PHON/EHS+Setup (replace the dot with a period .) New user rules cannot post URL.

It really is easy.