VPN server couldn't register remote phone

Hi

On my remote IP phone sangome s700 the account is not registered.
On the freepbx:
tail -f /var/log/messages:
Jan 13 03:27:50 localhost openvpn[6538]: Initialization Sequence Completed
Jan 13 03:27:52 localhost ntpd[1651]: Listen normally on 9 tun0 10.8.0.1 UDP 123
Jan 13 03:27:52 localhost ntpd[1651]: peers refreshed
Jan 13 03:29:33 localhost ntpd[1651]: 0.0.0.0 c612 02 freq_set kernel -17.824 PPM
Jan 13 03:29:33 localhost ntpd[1651]: 0.0.0.0 c615 05 clock_sync
Jan 13 03:32:27 localhost openvpn[6538]: WAN_IP_REMOTE:33032 TLS: Initial packet from [AF_INET]103.17.45.190:33032, sid=5d0e129b 7ada5f29
Jan 13 03:32:29 localhost openvpn[6538]: WAN_IP_REMOTE:33032 CRL CHECK OK: CN=FreePBX
[…]
Jan 13 03:32:29 localhost openvpn[6538]: client0/WAN_IP_REMOTE:33032 MULTI: Learn: 10.8.0.2 -> client0/103.17.45.190:33032
Jan 13 03:32:29 localhost openvpn[6538]: client0/WAN_IP_REMOTE103.17.45.190:33032 MULTI: primary virtual IP for client0/103.17.45.190:33032: 10.8.0.2
Jan 13 03:32:33 localhost openvpn[6538]: client0/WAN_IP_REMOTE103.17.45.190:33032 PUSH: Received control message: ‘PUSH_REQUEST’
Jan 13 03:32:33 localhost openvpn[6538]: client0/WAN_IP_REMOTE:33032 send_push_reply(): safe_cap=940
Jan 13 03:32:33 localhost openvpn[6538]: client0/WAN_IP_REMOTE:33032 SENT CONTROL [client0]: ‘PUSH_REPLY,route-gateway 10.8.0.1,topology subnet,ping 10,ping-restart 120,ifconfig 10.8.0.2 255.255.255.0’ (status=1)

So it’s seems to be ok

cat /etc/openvpn/sysadmin_server1-status.log
TITLE OpenVPN 2.3.7 x86_64-redhat-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [IPv6] built on Jun 9 2015
TIME Sat Jan 13 03:47:56 2018 1515775676
HEADER CLIENT_LIST Common Name Real Address Virtual Address Bytes Received Bytes Sent Connected Since Connected Since (time_t) Username
CLIENT_LIST client0 WAN_IP_REMOTE:44552 10.8.0.2 5780 5964 Sat Jan 13 03:41:58 2018 1515775318 UNDEF
HEADER ROUTING_TABLE Virtual Address Common Name Real Address Last Ref Last Ref (time_t)
ROUTING_TABLE 10.8.0.2 client0 WAN_IP_REMOTE:44552 Sat Jan 13 03:42:04 2018 1515775324
GLOBAL_STATS Max bcast/mcast queue length 0

Idem seems to be ok

On the remote IP phone I got a VPN address 10.8.0.2

I read this post:

So I put the http://login:password @WAN_IP_LOCAL_FREEPBX:83 with no success

And there is nothing interesting in /var/log/httpd/acces_log

And I can’t phone,

What should I do now?
Is there some other port to redirect on the main router of the subnet of the freepbx?
I think I’m close to solve.

get some more log.
I went on the web gui of ip phone.
Management / configuration /Sytem log / download system log :

[01-13 05:16:23 50:19:73] SIP: aid 0, cid 0, tid 0, did 0, REQUEST: REGISTER, Event: 2
[01-13 05:16:23 50:19:73] SipProc:aid 0 enter NoAnswer SIP_REGISTRATION_FAILURE ====
[01-13 05:16:23 50:19:73] CALL: State=0x60, Event=0x31e, Chn=0
[01-13 05:16:23 50:19:73] CallCtl: SendEvent2Lcm: aid 0, Line: 0, event 0x8d3
[01-13 05:16:23 50:19:73] GUI: Receive Call Register Failed!
[01-13 05:16:23 50:19:73] LCM: Select aid:0
[01-13 05:16:23 50:19:73] L2C: LCM set aid 0
[01-13 05:16:23 50:19:73] SIP: aid 0, Need Re-Register after 128 seconds…
[01-13 05:16:27 50:19:73] DNSC: Domain myname.ddns.blabla, ip WAN_IP_SUBNET_FREEPBX, TTL 4
[01-13 05:16:32 50:19:73] DNSC: resolv HostName – myname.ddns.blabla
[01-13 05:16:32 50:19:73] DNSC: Domain myname.ddns.blabla, ip WAN_IP_SUBNET_FREEPBX TTL 59
[01-13 05:16:35 50:19:73] Open /dev/ttyS1
[01-13 05:16:35 50:19:73] Baudrate is 2400

[01-13 05:16:35 50:19:73] init_ehs_mode

[01-13 05:16:36 50:19:73] GUI: set brightness:29
[01-13 05:16:57 50:19:73] WEBS: reading web file /tmp/webres/configuration.htm 27006
[01-13 05:16:57 50:19:73] WEBS: Write web file 26002
[01-13 05:17:10 50:19:73] SYSLOG: load flash Flie 2 -1
[01-13 05:17:11 50:19:73] SYSLOG: read flash Flie /hlfs/message02 size = 1050248
[01-13 05:17:12 50:19:73] SYSLOG: read flash Flie /hlfs/message01 size = 410252

Does it help?

asterisk -rvvvvd

localhost*CLI> sip show peers
Name/username Host Dyn Forcerport Comedia ACL Port Status Description
1/1 10.66.0.180 D No No A 5060 OK (13 ms)
2/2 10.66.0.235 D No No A 5060 OK (22 ms)
3/3 10.66.0.154 D No No A 5060 OK (16 ms)
4/4 10.66.0.152 D No No A 5060 OK (10 ms)
5 (Unspecified) D No No A 0 UNKNOWN
vega50/vega50 10.66.0.3 D Yes Yes 5060 Unmonitored
vegaOut/vega50 10.66.0.3 Yes Yes 5060 Unmonitored

localhost*CLI> sip set debug peer 5
Unable to get IP address of peer ‘5’

Ansd 5 is the ip phone not registered.

How an I debug?

localhostCLI>
[2018-01-13 08:04:23] DEBUG[4827]: manager.c:5294 process_message: Running action ‘Login’
[2018-01-13 08:04:23] DEBUG[4827]: manager.c:5294 process_message: Running action ‘Command’
[2018-01-13 08:04:23] DEBUG[4827]: manager.c:5294 process_message: Running action ‘Command’
[2018-01-13 08:04:23] DEBUG[4827]: manager.c:5294 process_message: Running action ‘Command’
[2018-01-13 08:04:28] DEBUG[4750]: chan_sip.c:8644 sip_alloc: Allocating new SIP dialog for [email protected][::1]:5060 - OPTIONS (No RTP)
[2018-01-13 08:04:28] DEBUG[4750]: chan_sip.c:8430 change_callid_pvt: SIP call-id changed from ‘[email protected][::1]:5060’ to ‘[email protected]:5060’
[2018-01-13 08:04:28] DEBUG[4750]: chan_sip.c:3373 initialize_initreq: Initializing initreq for method OPTIONS - callid [email protected]:5060
[2018-01-13 08:04:28] DEBUG[4750]: chan_sip.c:4434 __sip_ack: Stopping retransmission on ‘[email protected]:5060’ of Request 102: Match Found
localhost
CLI>

I tried to google but find nothing about sip stopping transmission

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.