Voxbeam not working when dialing italian numbers

I configured an outbound trunk with Voxbeam.

If with this trunk I call a swiss mobile number +417xxxxx it works well in 100% of cases. See

If I call an Italian number number +393xxxxxx it fails in 100% of cases. A recorded voices says that all circuits are busy and that I should call later.
See gigaset_ko - Pastebin.com

The behavior is the same with platinum, gold, silver and call center routes.
What is wrong with the calls to Italian numbers?

Best regards

You will have to call Voxbeam.

Yes, I opened a ticket to Voxbeam. Possibly they will answer after the weekend. But I am puzzled that a so popular provider like Voxbeam has such a showstopper bug, which cannot be solved or circumvented with a proper freepbx setting.

Just guessing here, is your system set up to transcode g729? Mine isn’t and failed with multiple trunking providers, including AnveoDirect where I had numerous carriers enabled. Yours failed differently, because you offer g729 and on line 642 of the paste you were offered only g729 from a media server at IDT. The log ended before you canceled or ended the call so I can’t tell what happened from there.

I’ll try in the morning with a g729-capable client.

When I did this test to which the paste refers, I had enabled alaw ulaw g723 g726 g729 both in the extension and in the trunk.
I did also another test with only alaw and ulaw and it failed as well.

Odd… I interrupted the log after hearing the recorded message “all circuits…”. Anyway I have done a new test. This time the log should be complete. voxbeam_ko - Pastebin.com
I heard the voice “all circuits are busy now…” 20-30 seconds after dialing. In this test I used silver routes.
If I should I give a try with different codec, can you tell my which codecs should I set in the extension and in the trunk?

Didn’t look at the log, but…what are your dial rules in the outgoing route/trunk?

EDIT: why would a provider just use g729? It’s alaw and g722 in Europe…as far as I know. Put g722 in front of alaw.

Did you exclude any codecs at the extension level?

The dial rules are to match any pattern. Anyhow, the full log shows that the invite is sent to Voxbeam and it is correct, so the dial rules work. And keep in mind that the call to Swiss numbers +417xxxxxx work well

I disallow “all” in the disallow field, and in the “allow” field allow the codecs that I mentioned above (alaw&ulaw&g723 &g726&g729)

What happens when you remove the codecs in the extension settings and just use the codecs defined in SIP settings. And remove the g729 codec in SIP settings.

I am just a user…no pro…

I did the test, same result: OK to call Swiss numbers, KO to call Italian numbers.
Now the INVITE to Voxbeam contains these codecs:

o=- 1298990297 1298990297 IN IP4
c=IN IP4
t=0 0
m=audio 17098 RTP/AVP 0 8 111 4 101
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:111 G726-32/8000
a=rtpmap:4 G723/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16

Full log here: voxbeam_ko_no_g729 - Pastebin.com

Read the Info regarding the codecs supported…

They mainly use 729a and 723…they dont support 722…and not even 711 at all locations. Is this a good provider?

Are you located in Italy or in Switzerland? If Switzerland there is sipcall.ch, which is a provider with no monthly fees. Just as an alternative for testing. Sipcall is reliable, I use it in Austria on one freePBX system.

What do you know about the +39349 number? I had trouble reaching it via numerous carriers, though have not yet tried a proper g729 setup. Two sources show that it was originally issued by Vodafone and ported to TIM. Is that correct? If ported, approximately when was it last ported?

This is my Italian phone number. You are right. I realized that there are troubles with this number right in these days. I talked with the support of Tiscali (the current provider of this number) and they told me that since 13th of June they have dismissed 3G and they only allow VOLTE and 4G. This was a surprise also for me. I checked my phone and I found that I had disabled VOLTE. So I enabled it. Now the situation is a bit better, but I cannot say that is perfect.

This is what I found:

  1. With Voxbeam, still doesn’t work. Here is the new full log, after enabling VOLTE in my cell. phone: tiscali_voxbeam_ko - Pastebin.com
  2. If I use the same configuration of Freepbx, except for the trunk, which I changed from Voxbam to a Dellmont provider - voipchief, sometimes the phone rings, with noticeable delay. However, the caller id is completely wrong and apparently random. Here is the full log of a test, in which the phone was ringing, but I terminated the call: tiscali_voipchief_ok - Pastebin.com
  3. If I use call my Tiscal number using Dellmont providers (freevoipdeal), and the Voipconnect softphone provided by Dellmont, the telephone rings and the caller id is correct in 100% of cases. I don’t have the full log, because the call didn’t pass through Asterisk.

BUT: there is a big BUT: this works well only if I use the Dellmont softphone. If I use the same Dellmont provider with a Gigaset Siemens A510IP, it doesn’t work.

In conclusion: there is still a big entropy. there are surely issues in my Tiscali SIM and / or in my cellular phone (a Doogee S51), but it would be nice to know what is the magic that makes the Voipconnect sofpthone of Dellmont works well in 100%of cases and with right caller id.
Maybe there is some trick with the codecs, and probably the issue is related to the change in Tiscali provider, which has dismissed 3G on 13th of June.
Another details that add more entropy is that I am currently in Switzerland and my Tiscali SIM is roaming and attached to Swiss Sunrise provider. I will try to repeat the test next time I travel in Germany or in Italy.

If someone is able to unravel this big mess, is a genius.

EDIT- as said, my Tiscali SIM is roaming abroad and connected to the Swiss Sunrise network. So I activated the manual selection of the network and I did tests connecting it to the following networks:

  • Swisscom (Swiss provider)
  • Salt (Swiss provider)
  • Telekom.de (German provider - in fact I live near the border with Germany)
    In all cases the SIM could receive calls without problem from my Freepbx: it was ringing immediately and with the correct caller id.
    I have no idea how to explain this.

You wrote “when I call an Italian number, it fails in 100% of cases”…so I thought you tested at least TWO Italian numbers :wink:
Yes, this is known in Europe…when you change the provider, sometimes there are problems and a different provider does not find you anymore.

Two suggestions:

  1. If you have a dualsim phone, buy a Swiss sim.
  2. Use a softphone app on your mobile phone.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.