Voiptalk outbound sip trunk

Hi There,

I’m new for freepbx and i don’t how it work and to troubleshoot.
I need your kind help to solve voiptalk outbound issue.

I cant make any outgoing call it said ‘the number you have dialed is not in service please check your number and try again’

Below is the logs:-

[2013-01-24 15:49:46] VERBOSE[3376] netsock2.c: == Using SIP RTP TOS bits 184
[2013-01-24 15:49:46] VERBOSE[3376] netsock2.c: == Using SIP RTP CoS mark 5
[2013-01-24 15:49:46] VERBOSE[6463] pbx.c: – Executing [[email protected]:1] Set(“SIP/710-000000be”, “__FROM_DID=+441355593400”) in new stack
[2013-01-24 15:49:46] VERBOSE[6463] pbx.c: – Executing [[email protected]:2] NoOp(“SIP/710-000000be”, “Received an unknown call with DID set to +441355593400”) in new stack
[2013-01-24 15:49:46] VERBOSE[6463] pbx.c: – Executing [[email protected]:3] Goto(“SIP/710-000000be”, “s,a2”) in new stack
[2013-01-24 15:49:46] VERBOSE[6463] pbx.c: – Goto (from-trunk,s,2)
[2013-01-24 15:49:46] VERBOSE[6463] pbx.c: – Executing [[email protected]:2] Answer(“SIP/710-000000be”, “”) in new stack
[2013-01-24 15:49:46] VERBOSE[6463] pbx.c: – Executing [[email protected]:3] Wait(“SIP/710-000000be”, “2”) in new stack
[2013-01-24 15:49:49] VERBOSE[6463] pbx.c: – Executing [[email protected]:4] Playback(“SIP/710-000000be”, “ss-noservice”) in new stack
[2013-01-24 15:49:49] VERBOSE[6463] file.c: – <SIP/710-000000be> Playing ‘ss-noservice.alaw’ (language ‘en’)
[2013-01-24 15:49:51] VERBOSE[6463] pbx.c: == Spawn extension (from-trunk, s, 4) exited non-zero on ‘SIP/710-000000be’
[2013-01-24 15:49:51] VERBOSE[6463] pbx.c: – Executing [[email protected]:1] Macro(“SIP/710-000000be”, “hangupcall,”) in new stack
[2013-01-24 15:49:51] VERBOSE[6463] pbx.c: – Executing [[email protected]:1] GotoIf(“SIP/710-000000be”, “1?theend”) in new stack
[2013-01-24 15:49:51] VERBOSE[6463] pbx.c: – Goto (macro-hangupcall,s,3)
[2013-01-24 15:49:51] VERBOSE[6463] pbx.c: – Executing [[email protected]:3] ExecIf(“SIP/710-000000be”, “0?Set(CDR(recordingfile)=)”) in new stack
[2013-01-24 15:49:51] VERBOSE[6463] pbx.c: – Executing [[email protected]:4] Hangup(“SIP/710-000000be”, “”) in new stack
[2013-01-24 15:49:51] VERBOSE[6463] app_macro.c: == Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘SIP/710-000000be’ in macro ‘hangupcall’
[2013-01-24 15:49:51] VERBOSE[6463] pbx.c: == Spawn extension (from-trunk, h, 1) exited non-zero on ‘SIP/710-000000be’

Please do let me know if you requires further information, your kind help on this matter is much appreciated.

This log is for an inbound call. Looks like you don’t even have the phone properly registered.

Why don’t you slow down, read a getting started guide, then come back and ask questions.

Good luck

Sorry for asking stupid questions, how to register a phone?
I manage to setup sip extension and able to make call, but i dont know how to make outgoing call on Voip sip trunk?

I can’t find help on internet or in freepbx doc? can you help me on this please???

is there anyone can help me on this issue???

Have you setup an outbound route and dial patterns to match where you are trying to dial?

1

3

3

can anyone help me??

Have you tried checking to make sure that the trunk is registered?
Issue a sip show registry in asterisk CLI.
Also issue sip show peers to make sure your phones are registered.
Hope this helps. Bed time here.

Trunk contexts are wrong. It’s from-trunk

That still doesn’t explain what I am trying to say. Is the phone registered (sip show peers or Asterisk info/sip from reports menu).

Any of the old “without tears” books will get you the basic concepts of setting up a trunk and a phone.

Many thanks for helping me on this issue, below is the sip registry status:-

Host dnsmgr Username Refresh State Reg.Time
voiptalk.org:5060 N 860286509 105 Registered Fri, 25 Jan 2013 14:38:17
1 SIP registrations.

Name/username Host Dyn Forcerport ACL Port Status
700 (Unspecified) D N A 0 UNKNOWN
701/701 192.168.1.174 D N A 5060 OK (9 ms)
705/705 111.111.111.111 D N A 5060 OK (22 ms)
voiptalk/860286509 77.240.48.94 N 5060 UNREACHABLE

I have changed Trunk contexts from-trunk but still no luck.

is there any website i can refer to setup trunk?

is there anyone can help???

I’m using voiptalk but on an IAX trunk. One thing I can see if that when you specify the Dialed Number Manipulation Rules you have specified:

()+0044|NXXNXXXXXX

So whatever you dial in your outbound rule the system will remove the leading 0044 and dial the rest of the number you enter. The letters above mean specific things:

X matches any digit from 0-9
Z matches any digit from 1-9
N matches any digit from 2-9

So after 0044 the rest of the number needs to start with a 2-9 have any two numbers 0-9 followed by one more number 2-9 followed by exactly six numbers 0-9.

This doesn’t make much sense.

Your outbound route will only pickup certain number also based on the same rules.

Voiptalk want you to specify numbers in International format dropping the leading “00”. So a very simply outbound route for UK numbers might be:

Geographic number:

()+0|1.
()+0|2.

This will allow you to dial any number starting 01 or 02. The “.” means any number of other digits so a bit of a catchall.

In the trunk definition you could use:

(44)+ |1.
(44)+ |2.

This will pick up the numbers from the outbound route (starting 01/02) and add 44 to the beginning (which Voiptalk wants) to construct the correct International format number.

You’ll probably want additional rules for mobiles:

0|7.

National rate/freephone:

0|8.
0|3.

And possibly premium rate:

0|9.

Implement them in the same was as above and you should be OK.

Obviously there are many and varied ways to “skin a cat” as it where. But this is just one.