VOIP suddently stopped working

Hello, I’m stuck since yesterday on this and can’t understand what’s going on.

I configured a FreePBX server and 6 phones in the office I work in, the VOIP provider is the same of our internet connection.
Everything was working fine, we upgraded our line to 2 channels and some days later everything stopped working. The credentials from the provider didn’t change since I tried connecting directly with Zoiper and it’s working fine.

Incoming calls are beeping on the caller side, but don’t appear in Asterisk logs. With sngrep I don’t see the invites incoming.
Outgoing calls works, but frequently they get automatically hang when the receiver answers, and are not dropped on caller’s side when the receiver hangs. In this case, I see invites in sngrep.

On Asterisk Info the PJSIP is online

I haven’t changed any configuration or added new devices in the network since when everything was working. If any information in particular can help (configurations, logs etc) tell me and I’ll add them now.

I’m sorry if something is unclear, I never dealt with anything about VOIP before and just need to fix this as soon as possible.

What does this mean? It sounds like some commercial restriction.

Apart from that, we need to know whether you use registration or IP based identification, and, for registration, have logs of the registrations. For the outgoing calls, we need logs of failing calls.

Thank you for your answer. Yes it’s a commercial restriction, the provider only allows 1 channel and you have to pay to have 2 channels. Unfortunately changing provider is too complicated since we should also change number.

We use registration, where do I find registrations logs? I’ve found grep “peer 'EXT”/var/log/asterisk/full* or to search registration in asterisk logs, but I don’t get anything.

For inbound call, there are no logs to show.
Here are the logs during an outbound call:
+390XXXXXXXXX VOIP NUMBER
+39340YYYYYYY RECEIVER NUMBER
https://pastebin.com/raw/ygj25Dga (too long to post it here and new users cannot post url)

[User privs upgraded to allow posing links - mod]

I’ll add informations while I find them in case they help (I can only post 1 media per comment)

|12299|[2022-05-05 12:32:28] VERBOSE[18850][C-0000000b] app_dial.c: Called PJSIP/[email protected]+390XXXXXXXXX||
|12300|[2022-05-05 12:32:33] VERBOSE[18850][C-0000000b] app_dial.c: PJSIP/+390XXXXXXXXX-00000015 is making progress passing it to PJSIP/210-00000014||
|12301|[2022-05-05 12:32:33] VERBOSE[18850][C-0000000b] app_dial.c: PJSIP/+390XXXXXXXXX-00000015 is making progress passing it to PJSIP/210-00000014||
|12302|[2022-05-05 12:32:35] VERBOSE[18850][C-0000000b] app_dial.c: PJSIP/+390XXXXXXXXX-00000015 answered PJSIP/210-00000014||

The provided call trace shows a normal outbound call that was answered and then hung up after 20 seconds. What was the problem with the call? Just missing audio?

No the call was working, the only problem was that when I hang on the responder the call doesn’t hang until I do it on the caller. (edit: forgot to mention that this morning outgoing calls automatically hung when responding. For some reason this suddently changed, I don’t even know why since I’m testing everything I find since this morning)
But the main problem is not that one, but the fact that incoming calls don’t arrive at all.

I’ve read somewhere that if no INVITE arrive, the problem is on the provider side. But with Zoiper everything works fine, so that shouldn’t be the case. Configurations were working until two days ago, and internal calls are still working fine.

UPDATE: I rebooted the router and now everything it’s working. Shouldn’t this be completely unrelated?

I am happy because I fixed the issue, but I’m pissed off since I still have no idea what the problem was or how I fixed it. Also, outgoing calls started giving “circuit is busy”, I changed the outbound proxy (my provider has 2 ip for that) nothing worked, I changed it back and now everything works.

I have no idea how but it’s resolved so it can be closed, thank you.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.