VoIP Server configuration in odoo 17 for Freepbx 16

Guys,

I am trying to configure Odoo 17 with Freepbx and they have given the following to setup.

image

Can anyone guide me for the ws:localhost part?

I am confused to enter the url here or should I have to create any url for ws on the FreePBX end

In FreePBX, go to Settings > Asterisk SIP Settings > SIP Settings tab. Scroll down and you should see your websocket settings, so make sure that one of them is turned on.

yes, it’s turned on.

ws - 0.0.0.0 - All = yes

wss - 0.0.0.0 - All = yes

I’m not familiar with Odoo but if it’s installed on your FreePBX server then what you have should work. If it’s a separate server, then it wouldn’t be localhost but the IP of your FreePBX server.

I am looking for the url which need to be entered in the WebSocket.

ws://localhost ?

What’s that for my PBX?

See previous reply.

setting is turned on but there is no url there.

image

I don’t know how else I can explain it to you. If the FreePBX server is separate from Odoo, put the IP address of the FreePBX server instead of localhost.

yes, odoo server is separate.

and what’s the default port for the websocket.

8088 for ws, 8089 for wss