VOIP.MS - Incoming - The number you have dialed is not in service

I followed this guided:
https://wiki.voip.ms/article/FreePBX_/_PBX_in_a_Flash

Outgoing is working, incoming is not. All incoming calls get: The number you have dialed is not in service.

When I look at the CDR I see incoming call:
Playback s [from-sip-external] ANSWERED 00:06
Congestion s [from-sip-external] ANSWERED 00:12

Inbound Routes are set to:
DID: Any
CID: Any
Destination: Extention 125

Peer Details:
host=sanjose2.voip.ms
username=xxx
fromuser=xxx
secret=xxx
transport=tls
encryption=yes
qualify=yes
qualifyfreq=50
nat=yes
type=peer
directmedia=no
context=from-trunk
insecure=invite
sendrpid=yes
trustrpid=yes
disallow=all
allow=g729&ulaw&gsm

Register String: tls://xxx:[email protected]:5061~300

Thanks for your help!

Not a good enough log.

https://wiki.freepbx.org/display/SUP/Providing+Great+Debug

  1. Use PJSIP.
    https://www.mangolassi.it/topic/12327/setting-up-a-sip-trunk-in-freepbx-13
    also read the 4th post in that thread for an advanced setting you likely will need to change.
  2. What @dicko said.
i[2020-01-22 07:37:58] VERBOSE[10829][C-00000031] file.c: <SIP/23.246.247.147-00000048> Playing 'ss-noservice.ulaw' (language 'en')

[2020-01-22 07:38:03] VERBOSE[10829][C-00000031] pbx.c: Executing [[email protected]:11] PlayTones(“SIP/23.246.247.147-00000048”, “congestion”) in new stack
[2020-01-22 07:38:03] VERBOSE[10829][C-00000031] pbx.c: Executing [[email protected]:12] Congestion(“SIP/23.246.247.147-00000048”, “5”) in new stack
[2020-01-22 07:38:03] VERBOSE[10829][C-00000031] pbx.c: Spawn extension (from-sip-external, s, 12) exited non-zero on ‘SIP/23.246.247.147-00000048’
[2020-01-22 07:38:03] VERBOSE[10829][C-00000031] pbx.c: Executing [[email protected]:1] Hangup(“SIP/23.246.247.147-00000048”, “”) in new stack
[2020-01-22 07:38:03] VERBOSE[10829][C-00000031] pbx.c: Spawn extension (from-sip-external, h, 1) exited non-zero on ‘SIP/23.246.247.147-00000048’

When you see calls go to the context ‘from-sip-external’ then the incoming INVITE (call) is not matching the trunk details you’ve set up. Possibly the call is arriving from a different IP than you have set for host?

So you think my trunk is setup incorrectly

Ended up doing PJSIP instead and had no problems.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.