VoIP.MS incoming route not working


#1

I have a hosted FreePBX running Asterisk 16.3.0, FreePBX 12.7.6-1904-1.sng7. I am using VoIP.MS for my trunk. It is registering properly and I can make calls fine but when I try to call into the system, I hit the PBX and get a “number disconnected or no longer in service” message. Here is the log file that was generated when I called in:
[2019-09-11 09:51:21] VERBOSE[11573][C-00000021] netsock2.c: Using SIP RTP TOS bits 184
[2019-09-11 09:51:21] VERBOSE[11573][C-00000021] netsock2.c: Using SIP RTP CoS mark 5
[2019-09-11 09:51:21] VERBOSE[21194][C-00000021] pbx.c: Executing [8509323456@from-sip-external:1] NoOp(“SIP/209.217.224.50-00000013”, “Received incoming SIP connection from unknown peer to 8509323456”) in new stack
[2019-09-11 09:51:21] VERBOSE[21194][C-00000021] pbx.c: Executing [8509323456@from-sip-external:2] Set(“SIP/209.217.224.50-00000013”, “DID=8509323456”) in new stack
[2019-09-11 09:51:21] VERBOSE[21194][C-00000021] pbx.c: Executing [8509323456@from-sip-external:3] Goto(“SIP/209.217.224.50-00000013”, “s,1”) in new stack
[2019-09-11 09:51:21] VERBOSE[21194][C-00000021] pbx_builtins.c: Goto (from-sip-external,s,1)
[2019-09-11 09:51:21] VERBOSE[21194][C-00000021] pbx.c: Executing [s@from-sip-external:1] GotoIf(“SIP/209.217.224.50-00000013”, “1?setlanguage:checkanon”) in new stack
[2019-09-11 09:51:21] VERBOSE[21194][C-00000021] pbx_builtins.c: Goto (from-sip-external,s,2)
[2019-09-11 09:51:21] VERBOSE[21194][C-00000021] pbx.c: Executing [s@from-sip-external:2] Set(“SIP/209.217.224.50-00000013”, “CHANNEL(language)=en”) in new stack
[2019-09-11 09:51:21] VERBOSE[21194][C-00000021] pbx.c: Executing [s@from-sip-external:3] GotoIf(“SIP/209.217.224.50-00000013”, “1?noanonymous”) in new stack
[2019-09-11 09:51:21] VERBOSE[21194][C-00000021] pbx_builtins.c: Goto (from-sip-external,s,5)
[2019-09-11 09:51:21] VERBOSE[21194][C-00000021] pbx.c: Executing [s@from-sip-external:5] Set(“SIP/209.217.224.50-00000013”, “TIMEOUT(absolute)=15”) in new stack
[2019-09-11 09:51:21] VERBOSE[21194][C-00000021] func_timeout.c: Channel will hangup at 2019-09-11 09:51:36.349 CDT.
[2019-09-11 09:51:21] VERBOSE[21194][C-00000021] pbx.c: Executing [s@from-sip-external:6] Set(“SIP/209.217.224.50-00000013”, “receveip=recvip”) in new stack
[2019-09-11 09:51:21] VERBOSE[21194][C-00000021] pbx.c: Executing [s@from-sip-external:7] Log(“SIP/209.217.224.50-00000013”, "WARNING,“Rejecting unknown SIP connection from 209.217.224.50"”) in new stack
[2019-09-11 09:51:21] WARNING[21194][C-00000021] Ext. s: “Rejecting unknown SIP connection from 209.217.224.50”
[2019-09-11 09:51:21] VERBOSE[21194][C-00000021] pbx.c: Executing [s@from-sip-external:8] Answer(“SIP/209.217.224.50-00000013”, “”) in new stack
[2019-09-11 09:51:21] VERBOSE[21194][C-00000021] pbx.c: Executing [s@from-sip-external:9] Wait(“SIP/209.217.224.50-00000013”, “2”) in new stack
[2019-09-11 09:51:23] VERBOSE[21194][C-00000021] pbx.c: Executing [s@from-sip-external:10] Playback(“SIP/209.217.224.50-00000013”, “ss-noservice”) in new stack
[2019-09-11 09:51:23] VERBOSE[21194][C-00000021] file.c: <SIP/209.217.224.50-00000013> Playing ‘ss-noservice.ulaw’ (language ‘en’)
[2019-09-11 09:51:26] VERBOSE[21194][C-00000021] pbx.c: Executing [h@from-sip-external:1] Hangup(“SIP/209.217.224.50-00000013”, “”) in new stack
[2019-09-11 09:51:26] VERBOSE[21194][C-00000021] pbx.c: Spawn extension (from-sip-external, h, 1) exited non-zero on ‘SIP/209.217.224.50-00000013’

I’ve never run into issues with VoIP.MS before. The trunk is setup as SIP not PJSIP and it shows as being registered on the PBX and the VoIP.MS dashboard. I also added the FQDN of the VoIP.MS server to the PBX firewall as a trusted network just to see if that would resolve the issue and it didn’t. Any ideas on what would be causing this?

Thanks in advance.


(Al Reilly) #2

Try changing the server that your registered to both on the portal and in your PBX. I have had issues with the NewYork 1-4 servers rejecting my calls.
Other than that, if you have a wireshark trace that would be very helpful


(Lorne Gaetz) #3

The inbound call is being flagged as anonymous, likely because it’s coming from an IP different than what you’ve set up for your trunk(s).


#4

I will try changing the server and see what happens. As far as the IP, I am using the FQDN of the provider, not an IP. When I ping the FQDN (atlanta2.voip.ms) it returns the IP that is in the logs.


(Dave Burgess) #5

With most names, especially ones with backup addresses, the IP address could be any address associated with “A” records for that name. Once cached, however, the IP address usually hangs around for a while. If this is a PJ-SIP connection, you can use the field for address matching to make all of the possible addresses for that hostname work. If you are using Chan-SIP, you are limited to a single IP address (names will not work reliably) per trunk, and you need individual trunks per IP address.


#6

So I tried a different VoIP.MS server and ran into the same issue. I then made sure I could ping the FQDN and resolve the correct IP from the FreePBX server command line and it is resolving correctly. As another test, I used the IP instead of the FQDN in the trunk settings and that didn’t help either. Still seeing the same error. Not sure where to go from here. I’ve got other servers using VoIP.MS with the same settings format (different account obviously) and don’t have any issues with those.


#7

Are you using chan_sip or pjsip? Follow the instructions to create one trunk for each IP that belongs to VoIP.ms if using chan_sip or use the match field if using pjsip.


#8

I’m currently using SIP with TLS. I’d use PJSIP but VoIP.MS doesn’t support it even though it will supposedly work. I am not 100% sure what I would need to use settings wise to try PJSIP with them and if it would support TLS or not.

I am still really baffled why I’m having this issue. I used the exact settings VoIP.MS has listed on their site. I contacted them and they double checked my trunk settings as well and said they were correct. I tried using the IP for the trunk for instead of the FQDN and that didn’t solve the issue. I still get the same IP coming in as anonymous.

If I can’t get this sorted today, I will probably need to try a different provider. Does anyone had any recommendations that are similar to VoIP.MS as far as pricing? I don’t have a lot of call volume so the low per minute model works well versus a set monthly price per trunk like something like SIPStation. Ultimately I’d like to get this figured out but I’ve tried everything suggested so far and that hasn’t made a difference.


#9

I got it figured. Somehow, TLS got turned off in my SIP settings page. I don’t know how that happened and why the Asterisk logs didn’t really help point me in that direction. Anyway, it’s all sorted. I appreciate the help.