VOIP intercom won't register

A bit of an odd problem here.

I got a VTO2000A intercom from Dahua with SIP firmware installed.

I’ve got numerous other phones that work without a glitch, but with this one I can’t even get it to register. It won’t even show up in the logs besides the fail2ban log.

[2017-05-09 23:34:15] SECURITY[2198] res_security_log.c: SecurityEvent="ChallengeSent",EventTV="1494365655-798519",Severity="Informational",Service="SIP",EventVersion="1",AccountID="8001",SessionID="0x7f33480cef28",LocalAddress="IPV4/UDP/",RemoteAddress="IPV4/UDP/",Challenge="0db26360"

The is the server the is the intercom.

I’ve done everything to test it, it just won’t work. It won’t even show up in the asterisk logs.

I once told the intercom to try to connect to my local PC, and then I used wireshark to see if it even did anything. It indeed did send a request register.

I am now tired and frustrated that this doesn’t work, while reading about people getting it to work on other forums, link below.


Anyone have an idea what could be the issue?

If it’s not showing up in the Asterisk logs, it probably isn’t communicating with the server.

I’ve got a similar problem right now that revolves around the use of VLANs (I just work here, it wasn’t my idea) and the local switch is blocking all of the traffic from the phones to the server because their VLAN information isn’t consistent.

So, I’d suggest wiresharking the connection at the server (tcpdump works just as well) and watch the back-and-forth traffic. You might find the problem that way. Note that I’m thinking that the “phone” is the problem. Maybe it’s trying to do a VLAN or the IP address is getting hosed up. This sounds to me like a basic, if obscure, networking issue.

I’ve fixed the issue.

The dahua firmware is so weird. A setting was hidden somewhere and I just disabled it and it works now…


How did you fix the issues? I have the same problem with my VTO2000A with SIP firmware.



Just delete the SIP realm, leave it empty.

You can find it in = Network Config -> Sip Server Config

Hope it helps.

Hello Guys

Im new here. I have a Dahua VTO2000A and Asterisk installed on a raspberry PI 2. Im trying to set up but im having some trouble. So i was wondering if someone could help me to set it up because im already moved in into my new house and i need Doorbell working. Im also happily paying for some help prbably over Teamviewer.

If anyone cud help me it would be a pleasure.

Kind regards Dominic

My mail is [email protected]

This is what worked for me, at any rate.