Voicemails disappearing


(D E) #1

I’ve just noticed voicemails are going into the ether. At first I thought it was only a new voicemail account for my sister I’d setup but now I see that the voicemail account we’ve used for the entire family hasn’t been working since god knows how long. I was putting it down to the faulty “minimum message length in seconds” setting which I’ve noticed on a different FreePBX install causes problems, but I’ve totally removed this setting and no difference. I’d like to check the mail log but can’t find it. The last voicemail email received was on 3rd Sept. Help please!! :slight_smile: :slight_smile:

1586    [2020-10-15 09:10:12] VERBOSE[17484][C-00000020] pbx.c: Executing [s-INSTRUCT@macro-vm:1] NoOp("IAX2/home_to_woo-11210", "NOMESSAGE (beeb only) voicemail") in new stack	
1587	[2020-10-15 09:10:12] VERBOSE[17484][C-00000020] pbx.c: Executing [s-INSTRUCT@macro-vm:2] Macro("IAX2/home_to_woo-11210", "get-vmcontext,4001") in new stack	
1588	[2020-10-15 09:10:12] VERBOSE[17484][C-00000020] pbx.c: Executing [s@macro-get-vmcontext:1] Set("IAX2/home_to_woo-11210", "VMCONTEXT=default") in new stack	
1589	[2020-10-15 09:10:12] VERBOSE[17484][C-00000020] pbx.c: Executing [s@macro-get-vmcontext:2] GotoIf("IAX2/home_to_woo-11210", "0?200:300") in new stack	
1590	[2020-10-15 09:10:12] VERBOSE[17484][C-00000020] pbx_builtins.c: Goto (macro-get-vmcontext,s,300)	
1591	[2020-10-15 09:10:12] VERBOSE[17484][C-00000020] pbx.c: Executing [s@macro-get-vmcontext:300] NoOp("IAX2/home_to_woo-11210", "") in new stack	
1592	[2020-10-15 09:10:12] VERBOSE[17484][C-00000020] pbx.c: Executing [s-INSTRUCT@macro-vm:3] VoiceMail("IAX2/home_to_woo-11210", "4001@default,s") in new stack	
1593	[2020-10-15 09:10:12] VERBOSE[17484][C-00000020] file.c: <IAX2/home_to_woo-11210> Playing 'beep.ulaw' (language 'en')	
1594	[2020-10-15 09:10:13] VERBOSE[17484][C-00000020] app_voicemail.c: Recording the message	
1595	[2020-10-15 09:10:13] VERBOSE[17484][C-00000020] app.c: x=0, open writing: /var/spool/asterisk/voicemail/default/4001/tmp/pnRIhE format: wav, 0x73f69150	
1596	[2020-10-15 09:10:18] VERBOSE[1269] asterisk.c: Remote UNIX connection	
1597	[2020-10-15 09:10:18] VERBOSE[17610] asterisk.c: Remote UNIX connection disconnected	
1598	[2020-10-15 09:10:20] VERBOSE[17484][C-00000020] app.c: User hung up	
1599	[2020-10-15 09:10:21] VERBOSE[17484][C-00000020] app_macro.c: Spawn extension (macro-vm, s-INSTRUCT, 3) exited non-zero on 'IAX2/home_to_woo-11210' in macro 'vm'	
1600	[2020-10-15 09:10:21] VERBOSE[17484][C-00000020] pbx.c: Spawn extension (ext-local, vmi4001, 1) exited non-zero on 'IAX2/home_to_woo-11210'	
1601	[2020-10-15 09:10:21] VERBOSE[17484][C-00000020] pbx.c: Executing [h@ext-local:1] Macro("IAX2/home_to_woo-11210", "hangupcall,") in new stack	
1602	[2020-10-15 09:10:21] VERBOSE[17484][C-00000020] pbx.c: Executing [s@macro-hangupcall:1] GotoIf("IAX2/home_to_woo-11210", "1?theend") in new stack	
1603	[2020-10-15 09:10:21] VERBOSE[17484][C-00000020] pbx_builtins.c: Goto (macro-hangupcall,s,3)	
1604	[2020-10-15 09:10:21] VERBOSE[17484][C-00000020] pbx.c: Executing [s@macro-hangupcall:3] ExecIf("IAX2/home_to_woo-11210", "0?Set(CDR(recordingfile)=)") in new stack	
1605	[2020-10-15 09:10:21] VERBOSE[17484][C-00000020] pbx.c: Executing [s@macro-hangupcall:4] NoOp("IAX2/home_to_woo-11210", " montior file= ") in new stack	
1606	[2020-10-15 09:10:21] VERBOSE[17484][C-00000020] pbx.c: Executing [s@macro-hangupcall:5] GotoIf("IAX2/home_to_woo-11210", "1?skipagi") in new stack	
1607	[2020-10-15 09:10:21] VERBOSE[17484][C-00000020] pbx_builtins.c: Goto (macro-hangupcall,s,7)	
1608	[2020-10-15 09:10:21] VERBOSE[17484][C-00000020] pbx.c: Executing [s@macro-hangupcall:7] Hangup("IAX2/home_to_woo-11210", "") in new stack	
1609	[2020-10-15 09:10:21] VERBOSE[17484][C-00000020] app_macro.c: Spawn extension (macro-hangupcall, s, 7) exited non-zero on 'IAX2/home_to_woo-11210' in macro 'hangupcall'	
1610	[2020-10-15 09:10:21] VERBOSE[17484][C-00000020] pbx.c: Spawn extension (ext-local, h, 1) exited non-zero on 'IAX2/home_to_woo-11210'	
1611	[2020-10-15 09:10:21] VERBOSE[17484][C-00000020] chan_iax2.c: Hungup 'IAX2/home_to_woo-11210'

(D E) #2

aha…finally found the maillog thanks to @Dicko /var/spool/mail/asterisk

looks like at some point recently gmail have tightened/changed things and…

    host ASPMX.L.GOOGLE.COM [64.233.167.27]
    SMTP error from remote mail server after pipelined end of data:
    550-5.7.1 [XX.30.XX.18] The IP you're using to send mail is not authorized to
    550-5.7.1 send email directly to our servers. Please use the SMTP relay at your
    550-5.7.1 service provider instead. Learn more at
    550 5.7.1  https://support.google.com/mail/?p=NotAuthorizedError w18si1824401wrc.309 - gsmtp

(D E) #3

Sorry, this was NOT a system issue but a Gmail one. Looks like at some point they’ve changed things. I reconfigured Exim4 and it’s working again.