Voicemail unable to save message error after trying to modify voicemail structure

I know what I tried to do is not standard, and it was really a stupid/advantageous idea, but now I am hopelessly lost on how to fix it.
I have 3 extensions in question. extension 1000, extension 1001 and extension 123. All of which were working. Then I decided to download new unavail.wav and busy.wav for both extension 1000 and 123. So I create folder 123 for the voicemail add the appropriate folders to this voicemail directory /var/spool/asterisk/voicemail/default/123 Finally I run the command fwconsole chown -m . and fwconsole chown then I restart asterisk. Now all three inboxes 1000 1001 and 123 are unable to accept voicemail. Note that extension 1000 and extension 123 don’t use my voicemail but instead say “please leave a message after the tone” (just that plain and vague), whereas extension 1001 still has the old unavail.wav and busy.wav which it plays. However even though it play the unavailable message when I hang up or press the # key it throws an error. The asterisk logs of current are not useful at all. Is there a way to get better logs from Asterisk (if so how), and why would running fwconsole chown cause this error to be happening? I 100% thought that fwconsole chown “anything” was completely safe to do… I was wrong.

Upon further investigation I see that no audio is working at all.

are the audio files you uploaded 16 bit mono 8k PCM and readable by your asterisk user?

they should be readable because of running fwconsole chown but I’m not sure if they are 16 bit mono 8k PCM… Should I remove these files and see if it fixes the problem?

Never a bad idea to fully undo that which you didn’t fully understand in the first place :wink:

Well how can I undo the commands fwconsole chown -m . and fwconsole chown? I believe these are the real culprits but I’m not sure… I also don’t know why I didn’t create a backup before doing this (had a moment of stupid in me).

No, not a good belief, that just normalizes ownership, you should just delete everything you did and recreate the voicemail boxes in a conventional fashion,

I’m just confused why extension 1001 would be effected at all if I didn’t modify any of its voicemail contents?

Sorry , I can’t help you there, comedian mail is a monolithic bolt on to asterisk that is basically rock solid, unless you ‘get clever’. Maybe accept the fact that you perhaps overreached while dabbling, delete it and ‘go with the force’

Sorry I realize now I wasn’t clear above, but the audio is 1 way… You can hear the audio on 1 side. Thus no message is being recorded because there is no audio! This is why I was thinking fwconsole chown must be the cause because audio worked both ways before… Looks like I really did me in this time. I deleted those new files and still same problem.

believe me, fwconsole did not hose you, like it it or not, your whole schmoozle is self inflicted.

Asterisk can ‘voicemail reload’ voicemail.conf as it is though outside of FreePBX

So apparently after removing all the added files, and restarting asterisk not once, but twice. It is working again. However a small note for anyone else who blindly did what I did. This effect of having 1 way audio was a 1 in a million chance that the mic on the device was shorting making no audio in the first place. That combined with the bad items added as @dicko mentioned above caused this error. I am marking his answer as to what the files should be above as the correct solution.

You can upload vm greeting recordings in UCP which will do all the heavy lifting for you. No need to think about audio file format/permission/location when doing this.

1 Like

Amazing thanks

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.