Voicemail To Email With SysAdminPro Not Delivering

Configured a fully updated & activated FreePBX build with SysAdmin Pro’s Email Setup menu to deliver voicemail to email to an existing valid email account hosted on Godaddy smtp servers but the email fails to be delivered.

FreePBX’s SMTP Email Setup menu appears as follows:

SMTP Server: Use External SMTP Server
My hostname: pbx.mydomain [mydomain substituted for my own]
My Origin: pbx.mydomain.com "
My Domain: mydomain.com "
Provider: Other
SMTP Server: [smtpout.secureserver.net]:465
Use Auth: Use Authentication
Use TLS: Use TLS
SASL Security Options: Require Both
Username:[email protected]
Password: mypassword

The Send From email account is known to work with inbound & outbound mail on Linux & Windows Mozilla thunderbird clients with port 465 although Mozilla calls their Connection Security SSL/TLS and their authentication method “Normal”. Therefore the authentication choices that are known to work on other client MUAs don’t align with FreePBX’s menu choices. Additionally Godaddy ports 80 & 3535 with no TLS were tried and those also fail.

When using TLS & port 465 the maillog shows the error:

Can’t show the error in the maillog because the site believes the data is a link and new posters can’t do that. The message is the postfix lost connection with the smtp relay.

Although the SASL Security Options show Require Both, all SASL options have been tried and still the email fails. Have also tried port 80 & 3535 with No TLS and still no success.

The SysAdmin Pro Email Setup page says that additional adjustments may be needed. I’m fine with editing /etc/postfix/main.cf and sasl_passwd but it would be useful to know what adjustments to make, and of course to know that the edits won’t be overwritten after each reboot.

Would very much appreciate any guidance on this.

SMTP Server: [smtpout.secureserver.net]:465

^^ don’t do that? Just put a hostname there. (This may not be the problem, but, it’s a good starting point)

Also, to paste code, just put it in code tags, which is ```` on a new line, and then code, and then another set of backticks.

Could you clarify that input? “smtpout.secureserver.net” is the Internet address Godaddy gives to use its email servers and that address works with the same email account on Linux Thunderbird clients.

The mods SysAdminPro’s Email setup makes to main.cf and sasl_passwd are shown below:

main.cf (additions made by SysAdmin Pro Email Setup):

smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options = noplaintext, noanonymous
smtp_use_tls = yes
smtp_tls_CAfile = /etc/pki/tls/certs/ca-bundle.crt
relayhost = [smtpout.secureserver.net]:465
myhostname = pbx.mydomain
mydomain = mydomain.com
myorigin = pbx.mydomain.com

sasl_passwd:

[smtpout.secureserver.net]:465 [email protected]:mypassword

Has this ever been resolved?

This is exactly the issue I am facing today - Error is “connection timed out”.

I am able to telnet and successfully login, providing BASE64 encoded uid and pswd.


[[email protected] ~]# telnet smtpout.secureserver.net 25
Trying 68.178.252.229…
Connected to smtpout.secureserver.net.
Escape character is ‘^]’.
220 p3plsmtpa12-09.prod.phx3.secureserver.net :SMTPAUTH: ESMTP
EHLO forwardintellect.com
250-p3plsmtpa12-09.prod.phx3.secureserver.net hello [x.x.x.x], secureserver.net
250-HELP
250-AUTH LOGIN PLAIN
250-SIZE 30000000
250-PIPELINING
250-8BITMIME
250 OK
AUTH LOGIN
334 VXNlcm5hbWU6
a–BASE64 Encoded User Name --xsZWN0LmNvbQ==
334 UGFzc3dvcmQ6
S05–BASE64 Encoded Password–TNiIQ==
235 … authentication succeeded :: 0s77cY1G1EJzH


Also noticed the Wiki shows the Email admin dialog for other SMTP as:

but my display shows:

Tried to use Godaddy relay-hosting server:

Oct 31 10:33:47 register postfix/smtp[2669]: 42ECA4C2BBA: to=[email protected], relay=none, delay=126747, delays=126717/0.13/30/0, dsn=4.4.1, status=deferred (connect to relay-hosting.secureserver.net[68.178.232.62]:25: Connection timed out)
Oct 31 10:33:52 register postfix/smtp[2668]: connect to relay-hosting.secureserver.net[68.178.232.62]:25: Connection timed out
Oct 31 10:33:52 register postfix/smtp[2668]: 678A64C2C43: to=[email protected], relay=none, delay=1518, delays=1483/0.09/35/0, dsn=4.4.1, status=deferred (connect to relay-hosting.secureserver.net[68.178.232.62]:25: Connection timed out)

Any suggestions would be appreciated.

Thanks.

Hi!

I am pretty sure that seeing “My Hostname”, “My Origin” and “My Domain” for an external SMTP server is a bug…

These are used to set the internal Postfix SMTP server’s myhostname, myorigin and mydomain (see http://www.postfix.org/postconf.5.html).

Have a nice day!

Nick

You can see they’re different, right?

Hi!

Is this server actually hosted on a godaddy server? Somehow I have a feeling port 25 is only opened to server on their network…

Good luck and have a nice day!

Nick

I am attempting to use the same relay-hosting server port=25 i am currently using to forward mail/notifications on a couple WP sites also hosted on Godaddy - so to your point, this may not work for a remote site.

The [telnet smtpout.secureserver.net 25] server was one of many tests I performed trying to get this to work. The point of providing that detail was to show that i can authenticate manually from the PBX console. The use of the [smtpout.secureserver.net] server is the server I can authenticate to and should be able to relay through using SSL port 465, but it fails with connection timed out error.

Sorry if the details are confusing, i have been trying to get this to work now for several days and the Godaddy support don’t provide much in the way of support for this kind of issue.

connection timed out error

This is a network level thing. Stop using that server, it’s not accessible from your machine. Find a server that IS accessible and use that.

And before you say ‘But it IS’, no, it’s not. You pasted a connection TO A DIFFERENT SERVER.

1 Like

So before i go completely nuts… wanted to say thanks for the help.

I decided to start fresh and go back to using the default relay associated with my hosting account. I called a friend of mine at GoDaddy and confirmed the config.

Stripped out comments to make brief: (main.cf)

queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
mail_owner = postfix
inet_interfaces = localhost
inet_protocols = all
mydestination = $myhostname, localhost.$mydomain, localhost
unknown_local_recipient_reject_code = 550
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases

debug_peer_level = 5

debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
ddd $daemon_directory/$process_name $process_id & sleep 5

sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.6.6/samples
readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES

smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options =

relayhost = smtpout.secureserver.net:25

I have stripped these out of the file normally - seems from Community posts this may be a bug and should

not be in file when using OTHER SMTP server

myhostname = pbx.localhost
mydomain = forwardintellect.com
myorigin = forwardintellect.com

Generates the following AUTHENTICATION ERROR

Nov 1 21:07:58 register postfix/smtp[32547]: 785FB4C013F: to=[email protected], relay=smtpout.secureserver.net[173.201.193.228]:25, delay=0.34, delays=0/0/0.25/0.09, dsn=5.0.0, status=bounced (host smtpout.secureserver.net[173.201.193.228] said: 530 authentication required (in reply to MAIL FROM command))
Nov 1 21:07:58 register postfix/qmgr[28457]: 785FB4C013F: removed

Is smtpout.secureserver.net in /etc/postfix/sasl_passwd?

Edit: I bet if you remove the :25 from the hostname, it’ll work fine. (Find whoever told you to put that there, and tell them they’re wrong, that’s the default port)

Okay, well now I am confused. I added brackets to the server name in the UI and now have email flowing through the DEBUG. I will test the email delivery via vmail option.

Hopefully this makes sense to you guys because it doesn’t to me.

Thanks again for your help.

Just made the same change (adding brackets around server name) to an older hosted release [6.12.65-32] that was having the same issue and it is now also sending email.

P.S. if i don’t add the port {":25") it doesn’t work.

I am not sure why this is working the way it is, but now they work.

Thanks,

Ed