Voicemail to email not working

I have followed the guide: Settings > Voicemail Admin > Settings > Email Settings > Server Email, set your from email. Also Attach voicemail is set to Yes

In Applications > Extensions > Voicemail, I have set Email Attachment to Yes.

Seems to be correct so far?

I cant receive any emails. Voicemail is working okay other than that, when I diall *97 on desk phone or soft phone it gets to the freepbx voicemail server.

Thank you all very much

In Applications > Extensions > Voicemail - Email attachment set to Yes, and make sure email address is populated.

Not sure if Voicemail email is using FreePBX SMTP, but might want to check:
Admin > System Admin > Email Settings
Make sure the settings are correct. You can also hit the debug button to see what’s up and if your emails are failing.

Hi, what settings do I put in here? Is it absolutely neccessary to use my FQDN? I have an FQDN set up with Amazon Route 53, which points to my public IP but just wondering if I have to use it or not

This could be the problem so thank you for the pointer

What i have populated.

My Hostname:
My Origin: freepbx.sangoma.local
My Domain: sangoma.local

Thank you, i will try this. Do you use Internal or External SMTP Server option?

I use the internal. The settings i’ve listed above works fine for me.
If you want to use an external SMTP, then you can point it to your on-prem as well, as that’s what i did when it was initially setup, and worked fine. I figured I’d just use the ‘free’ one since it was available. I did not have to whitelist it either.

Internal with

My Hostname:
My Origin: freepbx.sangoma.local
My Domain: sangoma.local

Does not seem to work sadly.

To clarify, I am ringing from one extension to mine and letting it go to voicemail. Then saying some test messages.

It works fine if I dail *97, I get through to voice mail and can hear the test message. So voice mail is working fine. However, no email at all from any FreePBX voicemail server

Perhaps someone can chime in on the settings.
Here’s the wiki on it:
https://wiki.freepbx.org/display/FPG/System+Admin+-+Email+Setup

This is what I have populated in Email Settings:

My Hostname:
My Origin: this can be whatever you want, it does not matter
My Domain: freepbx.local

Try changing the My Domain field to freepbx.local on your system and let us know

Still can’t get it to work.

I will try come back to this another time because its not working and I have tried several different methods (internal, external, Office365 and Gmail)