Voicemail notifications do not email

Hello all,

FreePBX version:
Asterisk Version:
System: Debian Lenny 5.0

I am running into an issue where Asterisk is not sending email notification of new voice mail. I tailed the /var/log/asterisk/full and have no email indication at all. After leaving a message, I tailed /var/log/mail.log and I received no new log entries.

I’ve tested/corrected the common issues, such as, reverse DNS checks, etc. I tested sendmail from the command line and even set it to ssmtp.

I changed the sendmail command in the voicemail.conf to “cat /> /tmp/asterisk_vm” to see if it was getting that far and there was no file written.

It truly seems as if asterisk is not sending the “sendmail” command or failing before it without log.

I realize that this may be more towards asterisk itself, but I’ve tried the forum there … no luck. Has anyone ran into / solved this issue?

I have been troubleshooting a problem with emailing voicemail for a few days now. Any pointers at this time would be greatly appreciated.


We finally solved this issue. It turned out to be a permission problem with the tmp email file created by asterisk. It was creating it with the wrong permissions, so what we ended up doing is editing app_voicemail.c to chmod the file 777 before it tried to send the e-mail. This seems to have worked with no side effects to be seen.

We’re still scratching our heads on why it would write the file with those permissions in the first place. Why did we run into this problem but nobody else seemed to have it?

based on “your solution” it looks like you didn’t follow the directions for installand and building a system properly.

asterisk and Apache should be running as the user asterisk. If so the permissions as defined work perfectly.

Because you changed that there are bound to be other issues going down the road also that you will bump into. If you’d like help please provide proper information on how you built your system and how it’s running so that we know it’s a not a “normal” setup.

We can also help in getting you to adjust it so it’s setup properly… But need to know how it is currently set to do that.