Voicemail notification to email


I want to send voicemail notifications to email, I think I did everything correctly but it does not work.
This is what I did:

  1. Admin → System Admin → Email Setup
    SMTP Email setup configuration:

Let say that my email is test@company com

SMPT Server: Use external smtp server
My hostname: company com
My origin: freepbx.sangoma.local
My domain: company com
Provider: Office 365
Username: test@company com
Password: (password of this email - test@company com)

  1. Applications → Extensions → Options of my extension number (voicemails are enable and saved for this) → Voicemail
    Email Address: email where i want to send notifications

  2. Settings → Voicemail Admin → Settings → Email Config
    Server Email: test@company com

Is my configuration correct? Do I have to add more configuration somewhere?
(I removed dots before ‘com’, as a new user I cant send links)

In the Email Setup page, click on “Debug” at the bottom. It should let you test your SMTP settings. Make sure that works.
I’m using the built-in smtp, and that is working fine for us. Can you try switching to the built-in to see if that works?

As for the extension, for me, each extension that wants voicemail to email, i would go to the voicemail tab of each extension and enable “Email attachment”

Pretty sure M365 doesn’t allow password auth for SMTP/Realy purposes, especially if security defaults are enabled and the account has MFA enabled on it.

You’ll need to setup a connector in M365 to allow email relay from your PBX. You probably want to follow steps in option #2 on this page: How to set up a multifunction device or application to send emails using Microsoft 365 or Office 365 | Microsoft Learn

And then configure postfix on the PBX to use M365 for email relay.

The GUI email setup has not worked right for years, despite being part of the SysAdminPro paid module. If you want it to work correctly you’ll need to use postfix to rewrite the from: address that gets incorrectly put onto emails. Lots and lots of info here about it.

Thanks for the responses.

I switched to ‘Use built in smtp server’ and then tried to debug.
After sending a test mail to my email I found this in the mail log:

(Host or domain name not found. Name service error for name=freepbx.sangoma.local type=AAAA: Host not found)

This is my configuration in email setup right now:
My hostname : company com
My origin: freepbx.sangoma.local
My domain: company com

do I have problem with my origin?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.