Voicemail not working or not activated

I am using FreePBX 13 installed using the method from FreePBX documentation.
I have configured the voicemail for extensions and even enabled them from the voicemail menu.

but instead of going to voicemail recording plays " the person you are calling is unavailable please try again"

and if we type voicemail command in the asterisk cli it’s not there and when test dialing from *97# call terminated not going to any menu.

The Logs are below for *97#

== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Executing [*[email protected]:1] Macro(“SIP/200-00000269”, “user-callerid,”) in new stack
– Executing [[email protected]:1] Set(“SIP/200-00000269”, “TOUCH_MONITOR=1532037918.891”) in new stack
– Executing [[email protected]:2] Set(“SIP/200-00000269”, “AMPUSER=200”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/200-00000269”, “0?report”) in new stack
– Executing [[email protected]:4] ExecIf(“SIP/200-00000269”, “1?Set(REALCALLERIDNUM=200)”) in new stack
– Executing [[email protected]:5] Set(“SIP/200-00000269”, “AMPUSER=200”) in new stack
– Executing [[email protected]:6] GotoIf(“SIP/200-00000269”, “0?limit”) in new stack
– Executing [[email protected]:7] Set(“SIP/200-00000269”, “AMPUSERCIDNAME=200”) in new stack
– Executing [[email protected]:8] GotoIf(“SIP/200-00000269”, “0?report”) in new stack
– Executing [[email protected]:9] Set(“SIP/200-00000269”, “AMPUSERCID=200”) in new stack
– Executing [[email protected]:10] Set(“SIP/200-00000269”, “__DIAL_OPTIONS=Ttr”) in new stack
– Executing [[email protected]:11] Set(“SIP/200-00000269”, “CALLERID(all)=“200” <200>”) in new stack
– Executing [[email protected]:12] GotoIf(“SIP/200-00000269”, “0?limit”) in new stack
– Executing [[email protected]:13] ExecIf(“SIP/200-00000269”, “0?Set(GROUP(concurrency_limit)=200)”) in new stack
– Executing [[email protected]:14] ExecIf(“SIP/200-00000269”, “0?Set(CHANNEL(language)=)”) in new stack
– Executing [[email protected]:15] NoOp(“SIP/200-00000269”, “Macro Depth is 1”) in new stack
– Executing [[email protected]:16] GotoIf(“SIP/200-00000269”, “1?report2:macroerror”) in new stack
– Goto (macro-user-callerid,s,17)
– Executing [[email protected]:17] GotoIf(“SIP/200-00000269”, “0?continue”) in new stack
– Executing [[email protected]:18] ExecIf(“SIP/200-00000269”, “1?Set(__CALLEE_ACCOUNCODE=)”) in new stack
– Executing [[email protected]:19] Set(“SIP/200-00000269”, “__TTL=64”) in new stack
– Executing [[email protected]:20] GotoIf(“SIP/200-00000269”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,36)
– Executing [[email protected]:36] Set(“SIP/200-00000269”, “CALLERID(number)=200”) in new stack
– Executing [[email protected]:37] Set(“SIP/200-00000269”, “CALLERID(name)=200”) in new stack
– Executing [[email protected]:38] GotoIf(“SIP/200-00000269”, “0?cnum”) in new stack
– Executing [[email protected]:39] Set(“SIP/200-00000269”, “CDR(cnam)=200”) in new stack
– Executing [[email protected]:40] Set(“SIP/200-00000269”, “CDR(cnum)=200”) in new stack
– Executing [[email protected]:41] Set(“SIP/200-00000269”, “CHANNEL(language)=en”) in new stack
– Executing [*[email protected]:2] Set(“SIP/200-00000269”, “CONNECTEDLINE(name-charset,i)=utf8”) in new stack
– Executing [*[email protected]-internal:3] Set(“SIP/200-00000269”, “CONNECTEDLINE(name,i)=My Voicemail”) in new stack
– Executing [*[email protected]:4] Set(“SIP/200-00000269”, “CONNECTEDLINE(num,i)=200”) in new stack
– Executing [*[email protected]:5] Answer(“SIP/200-00000269”, “”) in new stack
– Executing [*[email protected]:6] Wait(“SIP/200-00000269”, “1”) in new stack
– Executing [*[email protected]:7] Macro(“SIP/200-00000269”, “get-vmcontext,200”) in new stack
– Executing [[email protected]:1] Set(“SIP/200-00000269”, “VMCONTEXT=default”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/200-00000269”, “0?200:300”) in new stack
– Goto (macro-get-vmcontext,s,300)
– Executing [[email protected]:300] NoOp(“SIP/200-00000269”, “”) in new stack
[2018-07-19 22:05:19] ERROR[26240][C-00000121]: pbx_functions.c:608 ast_func_read: Function VM_INFO not registered
[2018-07-19 22:05:19] WARNING[26240][C-00000121]: func_logic.c:192 acf_if: Syntax IF(?[][:]) (expr must be non-null, and either or must be non-null)
[2018-07-19 22:05:19] WARNING[26240][C-00000121]: func_logic.c:193 acf_if: In this case, =’’, =‘SUCCESS’, and =‘FAILED’
– Executing [*[email protected]:8] Set(“SIP/200-00000269”, “VMBOXEXISTSSTATUS=”) in new stack
– Executing [*[email protected]:9] GotoIf(“SIP/200-00000269”, “0?mbexist”) in new stack
[2018-07-19 22:05:19] WARNING[26240][C-00000121]: pbx.c:2864 pbx_extension_helper: No application ‘VoiceMailMain’ for extension (from-internal, *97, 10)
== Spawn extension (from-internal, *97, 10) exited non-zero on ‘SIP/200-00000269’
– Executing [[email protected]:1] Macro(“SIP/200-00000269”, “hangupcall”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/200-00000269”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] ExecIf(“SIP/200-00000269”, “0?Set(CDR(recordingfile)=)”) in new stack
– Executing [[email protected]:4] Hangup(“SIP/200-00000269”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘SIP/200-00000269’ in macro ‘hangupcall’
== Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/200-00000269’

and when I checked in the Voicemail admin it shows like this

image

image

Any help would be greatly appreciated.

Looks like the voicemail module is not loaded. From a healthy system:

lgaetz*CLI> module show like app_voicemail.so
Module                         Description                              Use Count  Status      Support Level
app_voicemail.so               Comedian Mail (Voicemail System)         0          Running              core
1 modules loaded

Module Description Use Count Status Support Level
app_voicemail.so Comedian Mail (Voicemail System) 0 Not Running core
1 modules loaded

Any update guys on this.

You need to enable the module. Check your module list and see what’s happening. Reboot after to make sure it starts up correctly.

how to enable the module and where to enable the module.

little guide required on this.

guys,

here is the output of loading the module voicemail.so

ip-172-31-30-115CLI> module load app_voicemail.so
Unable to load module app_voicemail.so
Command ‘module load app_voicemail.so’ failed.
== Parsing ‘/etc/asterisk/voicemail.conf’: Found
[2018-07-22 18:47:48] WARNING[13533]: app_voicemail.c:13845 actual_load_config: maxsilence should be less than minsecs or you may get empty messages
== Registered application ‘VoiceMail’
== Registered application ‘VoiceMailMain’
== Registered application ‘MailboxExists’
== Registered application ‘VMAuthenticate’
== Registered application ‘VoiceMailPlayMsg’
== Registered application ‘VMSayName’
== Registered custom function ‘MAILBOX_EXISTS’
== Registered custom function ‘VM_INFO’
== Manager registered action VoicemailUsersList
== Manager registered action VoicemailRefresh
[2018-07-22 18:47:48] WARNING[13533]: app.c:505 __ast_vm_register: Voicemail provider already registered by res_mwi_external.
[2018-07-22 18:47:48] ERROR[13533]: app_voicemail.c:15058 load_module: Failure registering as a voicemail provider
== Unregistered application ‘VoiceMail’
== Unregistered application ‘VoiceMailMain’
== Unregistered application ‘MailboxExists’
== Unregistered application ‘VMAuthenticate’
== Unregistered application ‘VoiceMailPlayMsg’
== Unregistered application ‘VMSayName’
== Unregistered custom function MAILBOX_EXISTS
== Unregistered custom function VM_INFO
== Manager unregistered action VoicemailUsersList
== Manager unregistered action VoicemailRefresh
ip-172-31-30-115
CLI>

Kindly I need your suggestions on this and I have to enable this as my production server is in service and voicemails are not working.

Guys Find the solution from one of the dicko post.

He is genius…

This is the solution.
At the asterisk cli:-

module unload res_mwi_external_ami
module unload res_mwi_external
module load app_voicemail

then add

noload = res_mwi_external.so
noload = res_mwi_external_ami.so

to /etc/asetrisk/modules.conf

Next time you build asterisk , only use the modules you are comfortable with using.

3 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.