Voicemail not beeping after prompt and cannot record new unavailable messages

Gidday, we have a new installation of FreePBX here upgraded to 2.6.0.1
When we call our voicemail extension and go through prompts to record unavailable message it plays ‘Please record your unavailable message after the tone’ then it hangs up on the caller.

    -- <SIP/8008-00001720> Playing 'vm-rec-unv' (language 'en')
  == Spawn extension (macro-vm, adef, 1) exited non-zero on 'SIP/8008-00001720' in macro 'vm'
  == Spawn extension (from-internal, *8008, 1) exited non-zero on 'SIP/8008-00001720'
    -- Executing [h@from-internal:1] Macro("SIP/8008-00001720", "hangupcall") in new stack
    -- Executing [s@macro-hangupcall:1] GotoIf("SIP/8008-00001720", "1?skiprg") in new stack
    -- Goto (macro-hangupcall,s,4)
    -- Executing [s@macro-hangupcall:4] GotoIf("SIP/8008-00001720", "1?skipblkvm") in new stack
    -- Goto (macro-hangupcall,s,7)
    -- Executing [s@macro-hangupcall:7] GotoIf("SIP/8008-00001720", "1?theend") in new stack
    -- Goto (macro-hangupcall,s,9)
    -- Executing [s@macro-hangupcall:9] Hangup("SIP/8008-00001720", "") in new stack
  == Spawn extension (macro-hangupcall, s, 9) exited non-zero on 'SIP/8008-00001720' in macro 'hangupcall'
  == Spawn extension (from-internal, h, 1) exited non-zero on 'SIP/8008-00001720'

Ripping my hair out over this one :frowning:

Also when callers are ringing in, they get the default 'The person at extension x is unavailable, please leave your message after the tone’
They get no tone!
just silence, then it says, ‘Thankyou’ and promptly hangs up on the caller also.

    -- <SIP/8008-00001723> Playing 'vm-theperson' (language 'en')
    -- <SIP/8008-00001723> Playing 'digits/8' (language 'en')
    -- <SIP/8008-00001723> Playing 'digits/0' (language 'en')
    -- <SIP/8008-00001723> Playing 'digits/0' (language 'en')
    -- <SIP/8008-00001723> Playing 'digits/8' (language 'en')
    -- <SIP/8008-00001723> Playing 'vm-isunavail' (language 'en')
    -- <SIP/8008-00001723> Playing 'vm-intro' (language 'en')
    -- Recording the message
    -- x=0, open writing:  /var/spool/asterisk/voicemail/default/8008/tmp/tFK6hH format: wav, 0x8503e00

Also driving our guys nuts :frowning:

Any help would be much appreciated, thanks.

Regards
Dan Clark
New Zealand

Ensure that you have changed your Direct Dial to Voicemail message type, in General Setting, from Default to something else e.g. Unavailable. Otherwise when you use follow-me and the like, your custom recorded message will not be played back. The Asterisk default message will be played back instead.

Here are the steps I used to create a personal message:

  1. Use your existing extension and dial *97
  2. You will be asked for your password (if you have entered one)
  3. When the Voicemail IVR starts, press 0
  4. You will then be given the choice what type of message you want to record. 1 is for your Unavailable message and 2 is for your Busy message. Choose the appropriate message you want to record
  5. Record your message “Thank you for calling, I am either busy elsewhere or on the phone. Please leave me your message and I will call you back as soon as I can”.
  6. Press 2 to review your message. Press 1 to save. Press 3 to re-record.

And I do hear the tone…

Gidday, thanks for your message, but yes I did exactly that the same way and when the IVR says ‘Please record your message after the tone’ it doesn’t play the tone.

Dan

I have FreePBX Base Version: 2.6.0.1 and have performed all module upgrades. And it seems to work for me… so let’s try to determine what is different.

Here is something, it works on my Grandstream GXP2000, but not on my free 3CX SIP phone. When I press 2 to record my busy message, it starts the message then beeps.

I wonder if FreePBX sends a beep command that your phones don’t understand…

What phones are you using?

I’ve found the problem now, some of the audio files were missing off the server, including the ‘beep’ file.
You have to make sure /var/lib/asterisk/sounds includes all the factory sounds.

Thanks anyways guys.

Cheers
Dan

Here is what I will put in my problem / solution guide:

PROBLEM:

New installation of FreePBX here upgraded to 2.6.0.1
When we call our voicemail extension and go through prompts to record unavailable message it plays ‘Please record your unavailable message after the tone’ then it hangs up on the caller.

Also when callers are ringing in, they get the default ‘The person at extension x is unavailable, please leave your message after the tone’, but they get no tone, just silence, then it says, ‘Thankyou’ and promptly hangs up on the caller also.

CAUSE:

Some of the audio files were missing off the server, including the ‘beep’ file.

SOLUTION:

You have to make sure /var/lib/asterisk/sounds includes all the factory sounds.

Anything that you can add to that ?