Voicemail Login problems

Hi,

I have installed the latest version of FreePBX and I’m having problems with voicemail, always getting “Login Incorrect”. I am very familiar with the setup and have been using asterisk/FreePBX since the early [email protected] days and haven’t had this issue before. I’m using the “default” context and RFC2833, voicemail module 2.0.3.4. I do not have the “Disable” option available on the Module Admin page, but I did re-install the module anyway (per some of the advice offerred for earlier versions). I also checked the voicemail config files and all looks OK.

I’m using the same softphone and setup that I have used for the last 3 years and I’m stumped. Anyone have any ideas or what else I should be looking at?

Thanks,

JC

I was a little short on info above, so I set the debug level to 6, dialed both *97 and *98 a few times. Sometimes I got

Incorrect password ‘7’ for user ‘1001’ (context = default)
– <SIP/1001-0887e720> Playing ‘vm-incorrect-mailbox’ (language ‘en’)

and sometimes I got

Incorrect password ‘’ for user ‘1001’ (context = default)
– <SIP/1001-0887e720> Playing ‘vm-incorrect-mailbox’ (language ‘en’)

In other words, the system gets my mailbox “1001” when I input it, but after asking for the password, sometimes it gets the first digit and sometimes it sees nothing. It always recieves my mailbox digits but seems to ignore my password digits.

Wierd. Any suggestions? Thanks.

JC

Still no luck with the above problem and I’ve checked all the posts regarding this issue. Does anyone have any ideas?

JC

Interesting - I came across this problem the other day and wasn’t able to figure it out either, although I am running an older version of FreePBX. What version of Asterisk are you using?

I initially thought that it could be a problem with DTMF detection, but that wasn’t it either (I’m using standard Aastra 9133i’s and never had an issue with them)

The strange part to me was that it was working earlier in the day and then all of a sudden refused to accept passwords.
Magically, it appears to have corrected itself as well, however I don’t like things like that - you never know when there could be a problem again.

M

I’m not near the system right now, but it is whatever version that comes with the most recent stable FREEPBX distro.

I’m still having the same issue, voicemail is completely useless for me. The odds of ever putting this into production is somewhere between slim and none at the moment. I’ve even re-compiled the entire system and still no login. DTMF doesn’t appear to be the problem since it reads my extension (see above) but just won’t read the password.

I wish someone within the forum could at least give me a hint as to how to troubleshoot this issue, but as you can see, you’re the first to send any type of reply since I first posted a month ago. Oh well… if you can think of anything at all to look at, please let me know.

JC

I don’t know what version of Asterisk comes with the latest “stable version of FREEPBX”, in fact I didn’t even know that FREEPBX was available in ISO format complete with Linux and Asterisk. Are you perhaps thinking of another distribution?

I suggest looking and capturing the console output when you call voicemail. Make sure you increase the debug and verbosity level - asterisk -vvvvvvvvvvvvvvvvvvvvvvvvvr
post that here.

M