VoiceMail issues

Hiya, I’m trying to get voicemail started however I’m getting this error:
pbx.c:2927 pbx_extension_helper: No application 'VoiceMailMain' for extension (from-internal, *97, 10)

The app_voicemail and app_voicemail_odbc are both installed from menuselect, and I’ve verified their installation on the system.

It appears to be able to connect to the database, and app_voicemail_odbc is running:

However the weird part is, when I run core show applications I’m not seeing anything about voicemail here. There’s a lot of applications outputted when I run this so I’m not going to post it but if you think I’d be useful I’ll add it to the replies. Thank you.

app_voicemail isn’t running

From Asterisk CLI:

module load <module name>

You should only load one voicemail app. FreePBX uses app_voicemail.

That errors out, won’t let me load that if app_voicemail_odbc is running.

You have your answer right here.

If I load in just app_voicemail as well I get the same error.

I am not sure if you need to restart Asterisk after loading Voicemail. I would try to restart.

I did, changed it in the config file.

You would need a noload line for app_voicemail_odbc also.

I did, noload obdc and load the regular voicemail one, still gives same error.

Alright, we had a server issue which prompted us to restart the server.
After the restart, everything just literally started working. We touched no further configuration.
So if you’re also here having the same issue I did, try restarting?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.