Voicemail issue

Hi all

We have just put our FreePBX into production and are having a strange issue with voicemail. Voicemails are being cut off mid speech after approximately 20 seconds with message thank you, goodbye when recording but all settings are set to the FreePBX defaults for example in voicemail admin maxmessagelength is set to 300 maxmessagesilence 10ms

I can confirm asterisk.conf has the line transmit_silence_during_record=yes

Many thanks in advance…

Share a call trace via pastebin showing the Asterisk full log when this happens: Providing Great Debug - Support Services - Documentation

Thankyou, I really appreciate your assistance in this. It was extension 207 to 208…

That’s 3 seconds, not 20, and therefore consistent with a caller who doesn’t like voicemail.

Dosen’t make sense to me as I did the test myself rang extension 208 and the voicemail cutt off after about 20 seconds…

There is more than one voicemail system interaction in the log. I was referring to the one at 13:36:01, which on more detailed checking is recording part of the greeting, rather than recording a message.

I think you are referring to the one that starts on line 301, at 13:43:03, starts recording at 13:43:16, and is terminated, with the message:

[2023-01-16 13:43:32] VERBOSE[66612][C-00000070] app.c: Took too long, cutting it short...

Ok, I have just done another paste @ FreePBX Voicemail issue - Pastebin.com

Call was 207 to 208 @ 14:17 if this helps.

Thanks again…

It’s being cut off by Asterisk at about 16 seconds into the recording, because the recording is too long.

As to why you believe that the limit is 300 seconds and Asterisk thinks that it is 15 or 16 seconds, I can’t really help, but you may want to look at the generated configuration file to see what value is being given to the voicemail system.

From what I can see it appears to be getting the correct value and as previously mentioned all my settings do look right and have not been changed from the defaults thus there may be a chance that there is a bug in FreePBX somewhere down the line. voicemail.conf matches settings in voicemail admin…



Sorted, in the end it was my fault as I had added the wrong parameter under Extensions\Voicemail\VM Options, I had “maxmessages=xx” assuming this meant max number of messages in the mailbox however I needed “maxmsg=xx”. It is now all working as intended and I am kicking myself…

Most (all?) App Voicemail admin parameters, including this one, are settable directly in the GUI using Voicemail Admin