Voicemail is not working the system keeps playing an error im-sorry an-error-has-occured

Asterisk 1.4.26
Freepbx 2.5.1.5
ubuntu 9.04 2.6.28-11-server

I did a new install and cannot for the life of me figure out why its not working
I keep getting the error im-sorry an-error-has-occured

Executing [[email protected]:7] Dial(“SIP/201-089c2a38”, “SIP/201|15|Ttr”) in new
stack
– Called 201
– SIP/201-089c4060 is ringing
– Nobody picked up in 15000 ms
– Executing [[email protected]:8] Set(“SIP/201-089c2a38”, “DIALSTATUS=BUSY”) in new stack
– Executing [[email protected]:9] GosubIf(“SIP/201-089c2a38”, “0?BUSY|1”) in new stack
– Executing [[email protected]:10] GotoIf(“SIP/201-089c2a38”, “0?exit|return”) in new stack
– Executing [[email protected]:11] Set(“SIP/201-089c2a38”, “SV_DIALSTATUS=BUSY”) in new stack
– Executing [[email protected]:12] GosubIf(“SIP/201-089c2a38”, “0?docfu|1”) in new stack
– Executing [[email protected]:13] GosubIf(“SIP/201-089c2a38”, “0?docfb|1”) in new stack
– Executing [[email protected]:14] Set(“SIP/201-089c2a38”, “DIALSTATUS=BUSY”) in new stack
– Executing [[email protected]:15] NoOp(“SIP/201-089c2a38”, “Voicemail is 201”) in new stack
– Executing [[email protected]:16] GotoIf(“SIP/201-089c2a38”, “0?s-BUSY|1”) in new stack
– Executing [[email protected]:17] NoOp(“SIP/201-089c2a38”, “Sending to Voicemail box 201”) in new stack
– Executing [[email protected]:18] Macro(“SIP/201-089c2a38”, “vm|201|BUSY|”) in new stack
– Executing [[email protected]:1] Macro(“SIP/201-089c2a38”, “user-callerid|SKIPTTL”) in new stack
– Executing [[email protected]:1] Set(“SIP/201-089c2a38”, “AMPUSER=201”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/201-089c2a38”, “0?report”) in new stack
– Executing [[email protected]:3] ExecIf(“SIP/201-089c2a38”, “0|Set|REALCALLERIDNUM=201”) in new stack
– Executing [[email protected]:4] Set(“SIP/201-089c2a38”, “AMPUSER=201”) in new stack
– Executing [[email protected]:5] Set(“SIP/201-089c2a38”, “AMPUSERCIDNAME=Lance Buttars”) in new stack
– Executing [[email protected]:6] GotoIf(“SIP/201-089c2a38”, “0?report”) in new stack
– Executing [[email protected]:7] Set(“SIP/201-089c2a38”, “AMPUSERCID=201”) in new stack
– Executing [[email protected]:8] Set(“SIP/201-089c2a38”, “CALLERID(all)=“Lance Buttars” <201>”) in new stack
– Executing [[email protected]:9] Set(“SIP/201-089c2a38”, “REALCALLERIDNUM=201”) in new stack
– Executing [[email protected]:10] ExecIf(“SIP/201-089c2a38”, “0|Set|CHANNEL(language)=”) in new stack
– Executing [[email protected]:11] GotoIf(“SIP/201-089c2a38”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,20)
– Executing [[email protected]:20] NoOp(“SIP/201-089c2a38”, “Using CallerID “Lance Buttars” <201>”) in new stack
– Executing [[email protected]:2] Set(“SIP/201-089c2a38”, “VMGAIN=”"") in new stack
– Executing [[email protected]:3] GotoIf(“SIP/201-089c2a38”, “1?vmx|1”) in new stack
– Goto (macro-vm,vmx,1)
– Executing [[email protected]:1] GotoIf(“SIP/201-089c2a38”, “0?s-BUSY|1”) in new stack
– Executing [[email protected]:2] Set(“SIP/201-089c2a38”, “MODE=busy”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/201-089c2a38”, “1?notdirect”) in new stack
– Goto (macro-vm,vmx,5)
– Executing [[email protected]:5] NoOp(“SIP/201-089c2a38”, "Checking if ext 201 is enabled: ") in new stack
– Executing [[email protected]:6] GotoIf(“SIP/201-089c2a38”, “1?s-BUSY|1”) in new stack
– Goto (macro-vm,s-BUSY,1)
– Executing [[email protected]:1] NoOp(“SIP/201-089c2a38”, “BUSY voicemail”) in new stack
– Executing [[email protected]:2] Macro(“SIP/201-089c2a38”, “get-vmcontext|201”) in new stack
– Executing [[email protected]:1] Set(“SIP/201-089c2a38”, “VMCONTEXT=other”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/201-089c2a38”, “0?200:300”) in new stack
– Goto (macro-get-vmcontext,s,300)
– Executing [[email protected]:300] NoOp(“SIP/201-089c2a38”, “”) in new stack
– Executing [[email protected]:3] VoiceMail(“SIP/201-089c2a38”, “[email protected]|b”) in new stack
– Executing [[email protected]:4] Goto(“SIP/201-089c2a38”, “exit-FAILED|1”) in new stack
– Goto (macro-vm,exit-FAILED,1)
– Executing [[email protected]:1] Playback(“SIP/201-089c2a38”, “im-sorry&an-error-has-occured”) in new stack
– <SIP/201-089c2a38> Playing ‘im-sorry’ (language ‘en’)
– <SIP/201-089c2a38> Playing ‘an-error-has-occured’ (language ‘en’)
– Executing [[email protected]:2] GotoIf(“SIP/201-089c2a38”, “0?exit-RETURN|1”) in new stack
– Executing [[email protected]:3] Hangup(“SIP/201-089c2a38”, “”) in new stack
== Spawn extension (macro-vm, exit-FAILED, 3) exited non-zero on ‘SIP/201-089c2a38’ in macro ‘vm’
== Spawn extension (macro-exten-vm, s, 18) exited non-zero on ‘SIP/201-089c2a38’ in macro ‘exten-vm’
== Spawn extension (from-internal, 201, 1) exited non-zero on ‘SIP/201-089c2a38’
– Executing [[email protected]:1] Macro(“SIP/201-089c2a38”, “hangupcall”) in new stack
– Executing [[email protected]:1] ResetCDR(“SIP/201-089c2a38”, “vw”) in new stack
– Executing [[email protected]:2] NoCDR(“SIP/201-089c2a38”, “”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/201-089c2a38”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,6)
– Executing [[email protected]:6] GotoIf(“SIP/201-089c2a38”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,9)
– Executing [[email protected]:9] GotoIf(“SIP/201-089c2a38”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,11)
– Executing [[email protected]:11] Hangup(“SIP/201-089c2a38”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on ‘SIP/201-089c2a38’ in macro ‘hangupcall’
== Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/201-089c2a38’

We had a similar problem and found the solution here.

http://www.mail-archive.com/[email protected]/msg00131.html

It seemed that the /etc/asterisk/voicemail.conf file was messed up. I matched it to the way the one here looked, with the corrections, and the voicemail is now working.

Hope this helps.

I am having the same problem. I only had one [] in voicemail.conf and delete it but did not work. How did you solve your problem?

My solutions to the problem was to rebuild the entire system. I don’t know what happened, but asterisk just did not compile right.

I redid everything from scratch again and it worked.