Voicemail I'm sorry an error has occurred

How do I troubleshoot voicemails not showing up on phones? Its on a pbxact version 10.13.66-22 PBX Version Asterisk 13.29.2 Callers call in and leave a message but the phone blf doesn’t show a new message, and if I check the voicemail, there are no new messages. I checked voicemail admin and useage and it shows 0 messages. If you press # after leaving a message, it says we are sorry an error has occurred. PBX and modules are up to date.
I restarted the pbx in the process of running updates.
The restapps and ucp daemons weren’t working when I first logged in, but updates and manually restart restapps fixed that.
I ran fwconsole chown.
I disabled voicemail for the extension, then re enabled it.
What else should I do to troubleshoot?

Check for strange formatting and/or unmatched brackets in /etc/asterisk/voicemail.conf

Forget to mention, I tried that and didn’t see anything that looked strange.

Pull a call trace of a failed vm and share via pastebin:

Looks like this old version of freepbx may not support pastebin directly from the cli? I created it manually tho. Untitled - FreePBX Pastebin

[2021-12-15 15:05:57] VERBOSE[19355][C-0000001f] app_voicemail.c: Recording was 3 seconds long but needs to be at least 5 - abandoning
Had them leave a longer test message and its working now.


set minsecs appropriately

Under settings → Voicemail Admin, you can set these limits.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.