Voicemail Greeting Will Not Playback For Review

Howdy folks. I have a relatively new distro install of FreePBX that has had an odd ‘quirk’ about it since install.

When a user tries to record their greeting, they cannot hear the playback for review.

I’ve done fwconsole chown, fwconsole restart, and verified that Asterisk is running as Asterisk.

This is a typical attempt, as see from the console:

    -- Executing [*[email protected]:109] GotoIf("PJSIP/202-00000010", "0?novmpw:vmpw") in new stack
    -- Goto (from-internal,*97,118)
    -- Executing [*[email protected]:118] VoiceMailMain("PJSIP/202-00000010", "[email protected]") in new stack
    -- <PJSIP/202-00000010> Playing 'vm-password.g722' (language 'en')
    -- <PJSIP/202-00000010> Playing 'vm-youhave.g722' (language 'en')
    -- <PJSIP/202-00000010> Playing 'vm-no.g722' (language 'en')
    -- <PJSIP/202-00000010> Playing 'vm-messages.g722' (language 'en')
    -- <PJSIP/202-00000010> Playing 'vm-opts.g722' (language 'en')
    -- <PJSIP/202-00000010> Playing 'vm-options.g722' (language 'en')
    -- Recording the message
    -- <PJSIP/202-00000010> Playing 'vm-rec-name.g722' (language 'en')
    -- <PJSIP/202-00000010> Playing 'beep.g722' (language 'en')
    -- x=0, open writing:  /var/spool/asterisk/voicemail/default/202/greet.tmp format: wav, 0x7fddf4000918
    -- User ended message by pressing #
    -- <PJSIP/202-00000010> Playing 'auth-thankyou.g722' (language 'en')
    -- <PJSIP/202-00000010> Playing 'vm-review.g722' (language 'en')
    -- Reviewing the message
    -- <PJSIP/202-00000010> Playing '/var/spool/asterisk/voicemail/default/202/greet.tmp.slin' (language 'en')
    -- <PJSIP/202-00000010> Playing 'vm-review.g722' (language 'en')
    -- Reviewing the message
    -- <PJSIP/202-00000010> Playing '/var/spool/asterisk/voicemail/default/202/greet.tmp.slin' (language 'en')
    -- <PJSIP/202-00000010> Playing 'vm-review.g722' (language 'en')
    -- Stopped music on hold on PJSIP/montreal8.voip.ms-0000000e
    -- <PJSIP/202-00000010> Playing 'vm-review.g722' (language 'en')
pbx01*CLI> ! ls /var/spool/asterisk/voicemail/default/202/greet.tmp.slin
ls: cannot access /var/spool/asterisk/voicemail/default/202/greet.tmp.slin: No such file or directory
    -- <PJSIP/202-00000010> Playing 'vm-review.g722' (language 'en')
pbx01*CLI> ! ls /var/spool/asterisk/voicemail/default/202/greet.tmp.*
    -- <PJSIP/202-00000010> Playing 'vm-review.g722' (language 'en')

… the first thing that strikes me here is that the recording is a WAV file, whereas the system is trying to playback an SLIN.

What is a likely related symptom is that voicemails also cannot be played back directly … the user cannot hear them on the phone. However, the WAV file attached to the email is perfectly fine to play back.

It’s the only Asterisk box I’m managing right now that I’ve seen this behaviour, so I’m at a bit of a loss. Can someone offer a pointer about what setting to tweak so that FPBX is both recording and playing back voicemail WAV files?

Thanks in advance!

– Michel

Where are they recording them?? Browser? Phone?

Per the log snippet I posted, via phone.

They call the voicemail system to record the greeting and the review playback cannot be heard.

Is it enabled the

Settings->Voicemail Admin->Settings->Review Message


When it was installed, it was set to “Yes”. When I just checked, I found it set to “No”, so I just changed it to “Yes” and clicked “Submit”.

When the screen refreshed, it was back to “No”. I’ve changed it to “Yes” three times now, and it always reverts to “No” on the next look; clearly, that’s broken.

What is interesting about this is that per the log snippet I posted, you can clearly see the system is allowing Reviewing the message, regardless of what the UI is saying.

That would be one for the Freepbx dudes, the authority is in



The other thing that comes to mind is does it do the same thing on a chan_sip device?

Seems to be working fine on my system. Try updating the voicemail module to edge.

fwconsole ma upgrade voicemail --edge
fwconsole chown