Voicemail from address, I'm losing my mind

Latest distro fully updated.

No matter what maps I create in postfix or voicemail.conf, voicemail comes from [email protected]

Driving me insane and it’s causing office 365 authentication to fail… Help!! I’ve never had this problem before on over 20 installations.

Silly question, if you go into Settings>Voicemail Admin>Settings Tab> Email Config Tab is it showing the email you set under Server Email?

Yep, those fields don’t change it no matter what you put in there.

From is [email protected] There’s not a single config file on the server that I can find that contains that.

perhaps try this. I’ve had to make generic entries before as well.

http://semi-legitimate.com/blog/item/how-to-rewrite-outgoing-address-in-postfix

Yep, tried that. Still sends as [email protected]

may seem overkill but i’ve had to do this as well lol.

[email protected] [email protected]
[email protected] [email protected]
@localhost.localdomain [email protected]
@localhost [email protected]
[email protected] [email protected]
[email protected] [email protected]
[email protected] [email protected]
[email protected] [email protected]

Apologies if i’m rehashing what you’ve done. Just trying to be thorough.

Negative ghostrider. Still [email protected]

Something is corrupt that’s for sure. I can at least change the hostname, I’ll make a mailbox “asterisk”

There is absolutely nothing ever configured to use [email protected] for the voicemail, and there’s only a few articles I’ve found describing this issue with no resolve.

Yea, i’m drawing a blank currently. Seems weird as this is usually an easy fix. If i think of anything else i’ll post back.

This was driving me crazy also! First you have to change the Email From String under Voicemail Admin/Settings/Email Config

. I think the Server Email is for Paging.

Second are you using the Debug feature of Sysadmin Pro/Email Setup to test? If so it looks like that will always use [email protected] as the from address. However when emailing an actual voicemail the from address shows up correctly :slight_smile: