Voicemail - External Notify setting

voicemail
freepbx
configuration
Tags: #<Tag:0x00007f91ce77b0c0> #<Tag:0x00007f91ce77af58> #<Tag:0x00007f91ce77adf0>

(Dave Meade) #1

I have a customized external script that I have set in the external notify field for voicemail to turn on/off BLF lights on administrator sets for shared vmboxes.

I have the field populated with a /usr/bin/blf.sh
That entry in turn creates the following entry in voicemail.conf
externnotify=/usr/bin/blf.sh

The problem is now whenever a module update is applied (think it is only voicemail modules) the field is overwritten and replaced with fwconsole voicemail.
Typically I would get around something being overwritten by putting it in the ***_custom.conf file but one doesn’t exist for voicemail.conf, nor is there an include in the file so that appears not to be an option

Thoughts on how to keep this setting in place so it is not overwritten would be appreciated…


(Lorne Gaetz) #2

As far as I know, the only module that writes that parameter in FreePBX is vmnotify. If you remove that module it should prevent it from overwriting.

As an aside, VM hints are a thing in the Distro and have been for ages. If your BLF buttons are programmed with *98<ext> the hint should be automatic.


(Dave Meade) #3

do not have vmnotify installed output from fwconsole ma list
image

I will give *98 a try I have been using this script (or some version of it) since way back in FreePBX ver 2.something work for our upgrades and new deployments so never bothered to look for an alternatve


(Lorne Gaetz) #4

What is the exact string automatically being written, it’s not fwconsole voicemail.


(Dave Meade) #5

Just upgraded a new system I’m getting ready to deploy and this is what is populated
image


(Dave Meade) #6

These are the modules that were updated:


(Dave Meade) #7

To whoever did what or changed what thank you Just upgraded another system and went in and checked and the external notify script is no longer being overwritten.