Voicemail Email sends "to check your voicemail with a web browser" string from Postfix

I set up Postfix to use Sendgrid to relay Voicemail emails (thanks @billsimon)

My issue is that in the email body there is a link
“Visit http://AMPWEBADDRESS/ucp to check your voicemail with a web browser.” which is being sent as “Visit https://u25628.ct.sendgrid.net/ls/click?upn=etcetc_long_string_edited
I had, prior to configuring Postfix, successfully changed that link to the IP of the box Settings>Voicemail Admin>Email Config but since configuring Postfix it ignores that and sends that URL instead.
Then I tried putting back to AMPWEBADDRESS after setting FreePBX Web Address in Advanced Settings to the IP address of the box, but that had no effect.

Assuming that this is the “Welcome email” that is being sent when you create a new user.

If so, the go to Admin → User Management → Settings → Host Name and change it there.

No, this is the email sent to the user when a voicemail is saved which includes the message as an attachment

Please show us a screenshot of Settings → Voicemail Admin → Settings → Email Config

As well as the output of:

cat /etc/asterisk/voicemail.conf | grep emailbody

emailbody=${VM_NAME},\n\nThere is a new voicemail in mailbox ${VM_MAILBOX}:\n\n\tFrom:\t${VM_CALLERID}\n\tLength:\t${VM_DUR} seconds\n\tDate:\t${VM_DATE}\n\nDial *98 to access your voicemail by phone.\nVisit to check your voicemail with a web browser.\n

Then this issue is on Sendgrid’s side.

The link will work. You can probably turn off Sendgrid tracking so that it doesn’t alter your links.

edit: Tracking Settings | Twilio


@billsimon That was it
@PitzKey Thanks for your help, it was SendGrid

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.