Voicemail cutting off at 10 seconds

Hello! I’m running FreePBX I figured out how to set up voicemail but it cuts off the recording at 10 seconds. In other words, as the user is leaving a voicemail, it hangs up at 10 seconds. I looked through this: Comedian Mail
per another posting, I adjusted:


  • maxsecs = 300
  • maxsilence = 120

None of this has worked. Is there anything that can be done to prevent it from hanging up after 10 seconds of recording a voicemail?

In /etc/asterisk/asterisk.conf, under [options]
If you change this, restart Asterisk.

If you already had this setting, or it doesn’t help, see

If you still have trouble, report whether this problem also occurs on internal calls.

I added the [options] section (it wasn’t already in the config file) then added the transmit string you mentioned. I then restarted it. Unfortuntely it still hangs up at 10 seconds.

I look at the thread you referenced… they mentioned:

" Try to set RTP keepalive on the sip channels to one second. it sends a CNG (comfort noise generation) frame to keep the session alive especially in NAT environments.

The name of the setting for the chan_sip driver is:

and for chan_pjsip is:

Where would rtp_keepalive=1 go?

In Asterisk SIP Settings, General tab, you should find an RTP Keep Alive setting.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.