Voicemail continually resets

FreePBX 2.11.0.0beta2.2
ubuntu-12.04.1-server-i386
asterisk 11.2.1

Everytime I call my voicemail it wants me to reset my password as if I’m a new user. I use *[email protected](IP Address). Not sure what to look at it. Did a scratch install & build of asterisk & freePBX 6 months ago. I have one extension (“phonerLite” softphone) monitoring two mailboxes. I register as extension 1001, there are 10 messages in box 100 - the other box I monitor. My softphone sees the 10 messages, but Comedy mail tells me there are no messages.

Things seemed to be working ok until I tried using the User Portal at which point VM became uncooperative. I looked at /var/spool/asterisk/voicemail/ and permissions seemed a bit odd to me and a symlink appeared to be missing. I changed it to what I felt looked reasonable, but no joy.

Then I uninstalled the VM module, and reinstalled it. Still no joy. At this point I’m out of ideas and welcome input from more experienced folks.

Thank you in advance.

P.S. I love the captcha. Finally one that doesn’t make me want to punch something.

Is the password for VM the same as the extension number, if it is change the password.

Thank you, that helped. No more password resets.