Voicemail Broken on Brand New Server

Brand spankin new FreePBX 13.0.192.16 with Asterisk 13.17.0

Doing our routine checks on in/out calls, two way audio, voicemail to email, etc., when I noticed I wasn’t getting any voicemail emails. I then noticed voicemails aren’t being stored on the phones (server I know) either.

This is a brand new, fully updated to 66-21 as explained here: https://wiki.freepbx.org/display/PPS/FreePBX-Distro-10.13.66

I saw a post by Andrew Nagy that said to do a voicemail reload in asterisk cli. Here’s what I get:

[[email protected] ~]# asterisk -rvvvvvvv
Asterisk 13.17.0, Copyright © 1999 - 2014, Digium, Inc. and others.
Created by Mark Spencer [email protected]
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘core show license’ for details.

Connected to Asterisk 13.17.0 currently running on v12 (pid = 5079)
v12CLI> voicemail reload
Reloading voicemail configuration…
== Parsing ‘/etc/asterisk/voicemail.conf’: Found
v12
CLI> exit
Asterisk cleanly ending (0).
Executing last minute cleanups
[[email protected] ~]#

Looks a bit shorter that what Andrew mentioned herer: Voicemail Not Working

Any ideas?

Put your voicemail conf file into pastebin

http://pastebin.freepbx.org/view/fe1231a6

Could it be because I have a space on one of the voicemail settings or something and that causes it to not work correctly? Or because the email format has an error in it?

Anybody?

We’re dead in the water trying to move users from our broken server, as mentioned Consistent Asterisk/FreePBX Crash Issue, but can’t because with a brand new FreePBX instance, voicemail is broken.

Voicemail isn’t broken. But you haven’t given us much to go on. Why don’t you try to create a voicemail and show us the dialplan.

Hi Andrew will do. Did you notice anything wrong with the pace bin you had me upload? As for the dial plan I will do it when I get back to the office however so you know we get all the way through to the point of being asked to leave a voicemail it just doesn’t seem to create the file.

So, found the issue, but still needs fixin. The dialplan says that the recording was only 2 seconds, and need to be at least 5. So I recorded a new message, and it made it over 10 seconds, and it still said it was too short! Except it said it was only 4 seconds, and needed to be at least 5. I then did a 20 second message and it saved.

What would cause this timing to be that off?

  • <SIP/9880-0000000e> Playing ‘beep.ulaw’ (language ‘en’)
    – Recording the message
    – x=0, open writing: /var/spool/asterisk/voicemail/default/9880/tmp/aGH9vP format: wav, 0x7f18f0010220
    – User hung up
    – Recording was 2 seconds long but needs to be at least 5 - abandoning

Your default voicemail settings are causing this.

Heads up: we made no changes like this to the default configuration. This is a brand new VM.

That is irrelevant. What I said is “your default voicemail settings are causing this”. Which is true. The default settings in voicemail are preventing you from leaving short messages which is to prevent voicemail phone charges from spammers.

You can configure these settings in admin/config.php?display=voicemail&action=settings

If Asterisk thinks that the message is shorter than it actually is, then you probably have silence detection misconfigured in Settings, Voicemail Admin, Settings tab, Limits tab.

1 Like

Iv’e seen on some 13 fresh installs that the the default limit wasn’t working unless you recorded messages longer than 30 seconds, once lowered to the lowest possible it worked.

I know… there’s issues.freepbx.org for this :expressionless: