Voicemail Box Full. An Error has occured?

So i have ran into an issue and i am completely stumped. Whenever a user tries to record a voicemail it says . “The person at extension XXX is unavailable…” Which is correct. And then immediately after that it says “the mailbox is currently full can’t save message. An error has occured” This happens for every mailbox on the system. I have tried removing all my IVR’s and just setting the DID pointing to an extenstion no dice. Every mailbox says this. I looked in the var/spool/voicemail folders no messages are saved there, and i have all the messages being sent to emails and being deleted from the inbox once sent. I am on freepbx v2.9 and voicemail module v2.9.0.6 ?

Is there a way i can completely wipe the vm system from my system and just do a complete rebuild of the VM system. I dont want to completely rebuild the entire Freepbx system if possible?


You probably just have corruption in /etc/asterisk/voicemail.conf

It’s just a text file. Use a real editor that showed all unprintable characters like vi and clean it up.

i just looked in vim voicemail.conf nothing unordinary?

“sorry ,but the users mailbox can’t accept more messages” is the exact thing it says. I am trully stumped.

Is the HD full?

What is the max number of voice mails set to?

HD is not full (400GB left of free space)

max voicemails is set to 10000, and currently there are none on the system (according to vm admin). As i said they are deleted immediatley off the system when email is sent?

What happens when you uncheck the delete option.

It would be nice to see some logs too.

What are permissions on /var/spool/asterisk/voicemail/default? If Asterisk can’t write to the directory it will also play the vm-mailboxfull message.

when unchecking the delete option same issue.

the permissions on the default folder are


what kind of logs would you like? (not a sip debug log…) what kind?

i just restored from a backup and now it appears to work…

very very strange… something was corrupt but now with the backup restored its ok.

had the same problem tonight. I was building a new CentOS 6.5 system and tried to migrate some files from my current production AsteriskNOW server. I can’t says exactly what was wrong but the fix was easy. 1) disable voicemail on each extension. 2) remove folders beneath /var/spool/astersik/voicemail 3) enable voicemail for the extensions again. new folders are created as needed. Of course I still need a solution to port the recordings :frowning: