Voicemail App Not Requiring Password


(Ruler2112) #1

I have the Sangoma phones we have in place set to require the voice mail password even when checking from the extension so that people should HAVE to enter a password in order to access voice mail. (Some of our employees are great at justifying bad behavior, such as checking their boss’ voice mail when they aren’t around.) However, when the voice mail application is started on the Sangoma phones, you’re put right into the voice mail without forcing you to enter any password.

I know this has to be a setting somewhere, but have been unable to find it. Can anyone direct me to where I can find this?


(Itzik) #2

Are you using PhoneApps or the traditional voicemail?


(Dave Burgess) #3

… and if you are using traditional voicemail, are you allowing the option to skip the password if the extension matches the mailbox number?


(Ruler2112) #4

The voice mail button on the phone starts the phone app, which requires no password.

If I dial in using *98, it prompts me to enter my password.


(Ruler2112) #5

I have ‘Require From Same Extension’ set to yes in the voice mail settings of the extension. This seems to work only when voice mail is checked using *98, not when checking from the phone app.


(Dave Burgess) #6

That makes sense. I don’t think the phone app is using the *98 method to log into the VM.


(Lorne Gaetz) #7

VM PIN for visual voicemail is not supported, but has been requested by others. Feel free to file a feature request for commercial product:
https://wiki.freepbx.org/display/SUP/How+to+open+a+feature+request


(Itzik) #8

And in the meantime you can switch to the old voicemail


(Ruler2112) #9

Huh… that’s certainly an odd design decision to not support a PIN in the voicemail app. (Not allowing random people to check voice mail from the phone is what the ‘Require from Same Extension’ box is all about, but this effectively nullifies that entire setting, allowing anyone with physical access to the phone to do anything in voice mail.) I’ll create a feature request for it - thanks for the info guys.


(system) closed #10

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.