Voicemail and contexts

Hi,

I’m using freePDX 2.0.1 (yeah, yeah - I’ll get to the beta soon) with asterisk 1.2.4 on gentoo, connecting via SIP with both Ekiga and a Grandstream.

I can check voicemail by calling *98nnn (where nnn is the extn), but *97 and *98 always come back with ‘incorrect password’. I’ve read somewhere that this is because the context is wrong, but for the life of me can’t figure it out.

In the Extensions section, I’ve got:

mailbox: [email protected]
vm context: default

(I’ve also tried mailbox: [email protected], which AFAIK it defaulted to, but with no luck).

Here’s what I see in the CLI when dialing *97:

[code:1]…snip…
– Executing Macro(“SIP/102-3dd3”, “get-vmcontext|102”) in new stack
– Executing Set(“SIP/102-3dd3”, “VMCONTEXT=default”) in new stack
– Executing GotoIf(“SIP/102-3dd3”, “0?200:300”) in new stack
– Goto (macro-get-vmcontext,s,300)
– Executing NoOp(“SIP/102-3dd3”, “”) in new stack
– Executing VoiceMailMain(“SIP/102-3dd3”, “[email protected]”) in new stack
– Playing ‘vm-password’ (language ‘en’)
– Incorrect password ‘’ for user ‘102’ (context = default)
– Playing ‘vm-incorrect’ (language ‘en’)
– Playing ‘vm-password’ (language ‘en’)[/code:1]

…and when dialing *98102:

[code:1] – Executing Macro(“SIP/102-0532”, “get-vmcontext|102”) in new stack
– Executing Set(“SIP/102-0532”, “VMCONTEXT=default”) in new stack
– Executing GotoIf(“SIP/102-0532”, “0?200:300”) in new stack
– Goto (macro-get-vmcontext,s,300)
– Executing NoOp(“SIP/102-0532”, “”) in new stack
– Executing VoiceMailMain(“SIP/102-0532”, “[email protected]”) in new stack
– Playing ‘vm-password’ (language ‘en’)
… starts playing message options[/code:1]

To me it looks like it’s getting the same context and executing the same stuff.

Any ideas where I’m going wrong?

Never mind :oops: I figured it out

mailbox: [email protected]
vm context: device

I have the same problem, I tried setting [email protected] and VM Context = device, I also tried default it does not work.
How did you fix it.

That was all I needed - make sure the bit after the ‘@’ for mailbox matches the vm context, and isn’t ‘default’. Which isn’t working - dialing *97 or *98nnn?

Could you send me a snip of CLI to that shows the contexts like you did in the first post?

Hi,

Here’s snip from CLI output when dialing *97:

[code:1] – Executing Macro(“SIP/102-53e8”, “get-vmcontext|102”) in new stack
– Executing Set(“SIP/102-53e8”, “VMCONTEXT=device”) in new stack
– Executing GotoIf(“SIP/102-53e8”, “0?200:300”) in new stack
– Goto (macro-get-vmcontext,s,300)
– Executing NoOp(“SIP/102-53e8”, “”) in new stack
– Executing VoiceMailMain(“SIP/102-53e8”, “[email protected]”) in new stack
– Playing ‘vm-password’ (language ‘en’)[/code:1]

Might be worth checking the files are getting written properly. In /etc/asterisk/voicemail.conf. I’ve got:

[code:1][general]
#include vm_general.inc
#include vm_email.inc
[default]
[device]
102 => 1234,Matt,[email protected],attach=no|saycid=yes|envelope=yes|delete=no[/code:1]

And in /etc/asterisk/sip_additional.conf:

[code:1][102]
username=102
type=friend
secret=1234
record_out=Adhoc
record_in=Adhoc
qualify=no
port=5060
nat=never
[email protected]
host=dynamic
dtmfmode=rfc2833
context=from-internal
canreinvite=no
callerid=Matt <102>
accountcode=102[/code:1]

Hope it helps!

I have the same problem.
Always said password incorrect.
I have tried the above solution but in don’t work for my.
I only want my own text on the voicemail. When i dial *77 en i record my message a can listed it by *99 but when you call to my voicemail after my message you get the text mailbox 50 is unavailable please leave a message after the tone, when done press the pound key. I wil remove that text. I have read in another forum that i have to call *98 or *97 but they always said my password is incorrect but it is correct…

Can anybody help me?

Thanx.

P.S. Sorry for my bad english, i’m from holland :slight_smile:

I am still having the same problem, Here is a little more information on my system. I am running Asterisk 1.2.7.1 I have FreePBX 2.0.1

I have made the changes as listed above and I have checked the files as mentioned above. But I continue to have the problem.
I even went into my dial plan and added the ‘s’ in teh *97 section so it would not ask for the password. (exten => _*98X.,4,VoiceMailMain(s${EXTEN:3}@${VMCONTEXT}))) this worked but none of the other VM commands worked. This has to be a context issus.

I have looked at the CLI and it looks like the context is correct for the VM but it doesn’t work

Don’t really know what to suggest, except posting the relevant parts of your setup and CLI output. Never know, a fresh pair of eyes may be able to spot something…

What does your voicemail.conf show. I had to clean my voicemail.conf. It didn’t like anything other then [default]… I was tring to add dept. like support or sales. Has anyone tried to use the dial by name?

David

[quote=“jvhowell”]I am still having the same problem, Here is a little more information on my system. I am running Asterisk 1.2.7.1 I have FreePBX 2.0.1

use the GUI to set up voicemail…

with freepbx gui do not edit the .conf files only hand edit the custom.conf files

but try not to edit if you want smooth updates down the line