Voice timezone issue after upgrade

We recently did the upgrade from FreePBX 13 to 14. Since then, the timestamp on voicemails has been in UTC. I checked into this, and found the timezone setting under Voicemail Admin (which we hadn’t needed set before - maybe it was just reading the server timezone by default? That is properly set.). I set this under Voicemail Admin, and applied the changes, but there is no change to how the timestamps are read. I can see the setting did get written into the voicemail.conf file, so I’m not sure what else to do. The format I used, which appears to be what I’m seeing elsewhere, is mountain for the name, and America/Edmonton|‘vm-received’ Q ‘digits/at’ IMp for the value.

My understanding is that setting it here should apply to all extensions that are using the default context; however, just to be thorough, I went and added tz=mountain to the voicemail options of one of the extensions. That did not make a difference either.

Hmmm…looks like a space got into my option string in the individual extension config. I’ve removed that, and that extension works. Still hoping to find a way to default all mailboxes, though…how can I do this? Also still a bit confused as to what changed, as we didn’t have any of this configured before and it just worked, but that may be one of life’s mysteries. :slight_smile:



To the [general] stanza of /etc/asterisk/voicemail.conf, from the cli

voicemail reload

Double check the timezone setting in System Admin and confirm from the bash prompt that it’s set properly with


If both are fine, reboot.

re: server time and reboot - I had done that. It turned out it was the space in the option string it didn’t like. Thanks, though!

re: adding to the general portion - thanks! I was looking/hoping for some way to do it in the GUI (for future maintainability by others), but if it’s not there then this is the way we’ll have to go. Strangely, the asterisk documentation I found didn’t actually show tz as something that could go under general. Glad to know it can!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.