Voice Mail Password Probelms

I have a new install of FreePBX running and went through all the upgrades for all modules. I am now at 2.6.0.0. I am a newbie and did search on this and found a few issues from 2006 that did not address this issue.

I can not seem to access the voicemail for extensions when I create them. I get a “incorrect password” error everytime I try to access with *97 or *98.

Here is my “voicemail.conf”

[general]
#include vm_general.inc
#include vm_email.inc
[default]
200 => 12345,Adam Office,attach=no|saycid=yes|envelope=yes|delete=no

Here is a debug from the asterisk console.

Asterisk 1.4.28, Copyright © 1999 - 2009 Digium, Inc. and others.
Created by Mark Spencer [email protected]
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘core show license’ for details.

Connected to Asterisk 1.4.28 currently running on asterisk (pid = 8237)
Verbosity is at least 3
– Executing [*[email protected]:1] Answer(“SIP/200-00000007”, “”) in new stack
– Executing [*[email protected]:2] Wait(“SIP/200-00000007”, “1”) in new stack
– Executing [*[email protected]:3] Macro(“SIP/200-00000007”, “user-callerid|”) in new stack
– Executing [[email protected]:1] Set(“SIP/200-00000007”, “AMPUSER=200”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/200-00000007”, “0?report”) in new stack
– Executing [[email protected]:3] ExecIf(“SIP/200-00000007”, “1|Set|REALCALLERIDNUM=200”) in new stack
– Executing [[email protected]:4] Set(“SIP/200-00000007”, “AMPUSER=200”) in new stack
– Executing [[email protected]:5] Set(“SIP/200-00000007”, “AMPUSERCIDNAME=Adam Office”) in new stack
– Executing [[email protected]:6] GotoIf(“SIP/200-00000007”, “0?report”) in new stack
– Executing [[email protected]:7] Set(“SIP/200-00000007”, “AMPUSERCID=200”) in new stack
– Executing [[email protected]:8] Set(“SIP/200-00000007”, “CALLERID(all)=“Adam Office” <200>”) in new stack
– Executing [[email protected]:9] ExecIf(“SIP/200-00000007”, “0|Set|CHANNEL(language)=”) in new stack
– Executing [[email protected]:10] GotoIf(“SIP/200-00000007”, “0?continue”) in new stack
– Executing [[email protected]:11] Set(“SIP/200-00000007”, “__TTL=64”) in new stack
– Executing [[email protected]:12] GotoIf(“SIP/200-00000007”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,19)
– Executing [[email protected]:19] NoOp(“SIP/200-00000007”, “Using CallerID “Adam Office” <200>”) in new stack
– Executing [*[email protected]:4] Macro(“SIP/200-00000007”, “get-vmcontext|200”) in new stack
– Executing [[email protected]:1] Set(“SIP/200-00000007”, “VMCONTEXT=default”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/200-00000007”, “0?200:300”) in new stack
– Goto (macro-get-vmcontext,s,300)
– Executing [[email protected]:300] NoOp(“SIP/200-00000007”, “”) in new stack
– Executing [*[email protected]:5] MailboxExists(“SIP/200-00000007”, “[email protected]”) in new stack
– Executing [*[email protected]:6] GotoIf(“SIP/200-00000007”, “1?mbexist”) in new stack
– Goto (from-internal,*97,106)
– Executing [*[email protected]:106] VoiceMailMain(“SIP/200-00000007”, “[email protected]”) in new stack
– <SIP/200-00000007> Playing ‘vm-password’ (language ‘en’)
– Incorrect password ‘1122334455’ for user ‘200’ (context = default)
– <SIP/200-00000007> Playing ‘vm-incorrect’ (language ‘en’)
– <SIP/200-00000007> Playing ‘vm-password’ (language ‘en’)
– Executing [[email protected]:1] Macro(“SIP/200-00000007”, “hangupcall”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/200-00000007”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,4)
– Executing [[email protected]:4] GotoIf(“SIP/200-00000007”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,7)
– Executing [[email protected]:7] GotoIf(“SIP/200-00000007”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,9)
– Executing [[email protected]:9] Hangup(“SIP/200-00000007”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 9) exited non-zero on ‘SIP/200-00000007’ in macro ‘hangupcall’
== Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/200-00000007’

Thank you in advance for anyhelp

Here is a debug at level 5

No such command ‘debug=5’ (type ‘help debug=5’ for other possible commands)
asteriskCLI> debug 5
No such command ‘debug 5’ (type ‘help debug 5’ for other possible commands)
asterisk
CLI> set debug 5
Core debug was 0 and is now 5
The ‘set debug’ command is deprecated and will be removed in a future release. Please use ‘core set debug’ instead.
Really destroying SIP dialog ‘[email protected]’ Method: REGISTER
– Executing [*[email protected]:1] Answer(“SIP/200-00000002”, “”) in new stack
– Executing [*[email protected]:2] Wait(“SIP/200-00000002”, “1”) in new stack
– Executing [*[email protected]:3] Macro(“SIP/200-00000002”, “user-callerid|”) in new stack
– Executing [[email protected]:1] Set(“SIP/200-00000002”, “AMPUSER=200”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/200-00000002”, “0?report”) in new stack
– Executing [[email protected]:3] ExecIf(“SIP/200-00000002”, “1|Set|REALCALLERIDNUM=200”) in new stack
– Executing [[email protected]:4] Set(“SIP/200-00000002”, “AMPUSER=200”) in new stack
– Executing [[email protected]:5] Set(“SIP/200-00000002”, “AMPUSERCIDNAME=Adam Office”) in new stack
– Executing [[email protected]:6] GotoIf(“SIP/200-00000002”, “0?report”) in new stack
– Executing [[email protected]:7] Set(“SIP/200-00000002”, “AMPUSERCID=200”) in new stack
– Executing [[email protected]:8] Set(“SIP/200-00000002”, “CALLERID(all)=“Adam Office” <200>”) in new stack
– Executing [[email protected]:9] ExecIf(“SIP/200-00000002”, “0|Set|CHANNEL(language)=”) in new stack
– Executing [[email protected]:10] GotoIf(“SIP/200-00000002”, “0?continue”) in new stack
– Executing [[email protected]:11] Set(“SIP/200-00000002”, “__TTL=64”) in new stack
– Executing [[email protected]:12] GotoIf(“SIP/200-00000002”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,19)
– Executing [[email protected]:19] NoOp(“SIP/200-00000002”, “Using CallerID “Adam Office” <200>”) in new stack
– Executing [*[email protected]:4] Macro(“SIP/200-00000002”, “get-vmcontext|200”) in new stack
– Executing [[email protected]:1] Set(“SIP/200-00000002”, “VMCONTEXT=default”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/200-00000002”, “0?200:300”) in new stack
– Goto (macro-get-vmcontext,s,300)
– Executing [[email protected]:300] NoOp(“SIP/200-00000002”, “”) in new stack
– Executing [*[email protected]:5] MailboxExists(“SIP/200-00000002”, “[email protected]”) in new stack
– Executing [*[email protected]:6] GotoIf(“SIP/200-00000002”, “1?mbexist”) in new stack
– Goto (from-internal,*97,106)
– Executing [*[email protected]:106] VoiceMailMain(“SIP/200-00000002”, “[email protected]”) in new stack
– <SIP/200-00000002> Playing ‘vm-password’ (language ‘en’)
– Incorrect password ‘1122334455’ for user ‘200’ (context = default)
– <SIP/200-00000002> Playing ‘vm-incorrect’ (language ‘en’)
Really destroying SIP dialog ‘4a77cfae7e039bfc’ Method: REGISTER
– <SIP/200-00000002> Playing ‘vm-password’ (language ‘en’)

Just in case, the SIP secret password for the extensions is different then the voicemail password. Here’s a webpage on how to setup voicemail. You set up the voicemail password farther down in the FreePBX Add Extension menu

Eugene,

Thank you for the suggestion. I did have separate password and the phone is properly registered. Thank you for the link, I will review and see if I am missing anything.

I did notice in the debug that is appears as if the password being seen in the log is wrong:

Playing ‘vm-password’ (language ‘en’)
– Incorrect password ‘1122334455’ for user ‘200’ (context = default)
– Playing ‘vm-incorrect’ (language ‘en’)

The password should be 12345 not 1122334455… Somehow it is appearing as double digits. Looks like a dtmf error on the handset or in the config. I will have to keep tinkering and reading. I am using the Aastra 57i handset for the record.

I reset the password to match the “double” entry of the digits “1122334455” and viola… I am in…

Now to figure out why this is happening… I have the extension and the phone set to rfc2833. The offers “RTP or SIP INFO” no matter how I set this I keep seeing it… I guess I have some “Googling” and reading ahead of me…

Hmmm… you might search on Echo cancellation. Configured in zapata.conf

Here are some notes I found on that:

PROBLEM:
WARNING[27450] chan_zap.c: Unable to request echo training on channel 1
CAUSE:
In zapata.conf
echocancel=yes
echocancelwhenbridged=no
echotraining=800
The reason that Asterisk is returning this error about echo training is that echo training is software based, and since a hardware echo can is in place, Asterisk is smart enough NOT to try to implement the software echo can as well.
The ONLY parameter required for echo cancellation to work is the echocancel=yes.
SOLUTION:
Simply remove echotraining=yes or set it to no, from your zapata.conf and the error will go away, and you won’t lose any functionality.
echocancel=yes
echocancelwhenbridged=no
;(if your phones are all on the local network: echocancelwhenbridged=no)
;(if you access FreePBX from remote: echocancelwhenbridged=yes)
echotraining=no

PROBLEM:
NO AUDIO ON ANALOG LINE Call on an analog line seems to ring and connect correctly but no audio
SOLUTION:
PiaF uses the OSLEC echo canceller which has provided significant improvement on echo problems. In order for this to operate correctly echotraining needs to be commented out in zapata.conf. The installation does not always comment it out so it needs to be checked. The same parameter needs done for every FXS extension, but this is done in FreePBX GUI. After defining the zap extension go back and change the echotraining parameter from its default 800 to “blank”.

I am not using and zapata analog equipment. interestingly I do not understand why this is only for VM, as this does not effect outbound dialing…

Still on the hunt, and thanks for the assistance, it is greatly appreciated.

I also had this issue, just on a standard Asterisk install, not using FreePBX. Resolved by setting:

Advanced Settings -> Global SIP -> RTP Settings -> DTFM Method: SIP INFO

When it’s set to BOTH, it causes this problem. You can also change it on the individual SIP Line if necessary.

Via configuration file for Global SIP:
sip dtmf method: 1