Voice mail password check failure

Among the other problems I’m having getting our Asterisk/FreePBX system working, I can’t get at voice mail messages that have been left for a given extension.

Here’s the voicemail being saved:

-- Goto (macro-vm,s-DIRECTDIAL,1)
-- Executing NoOp("Zap/17-1", "DIRECTDIAL voicemail") in new stack
-- Executing Macro("Zap/17-1", "get-vmcontext|2653") in new stack
-- Executing Set("Zap/17-1", "VMCONTEXT=default") in new stack
-- Executing GotoIf("Zap/17-1", "0?200:300") in new stack
-- Goto (macro-get-vmcontext,s,300)
-- Executing NoOp("Zap/17-1", "") in new stack
-- Executing VoiceMail("Zap/17-1", "[email protected]|g(8)") in new stack
-- Playing 'vm-intro' (language 'en')
-- Playing 'beep' (language 'en')
-- Recording the message
-- x=0, open writing:  /var/spool/asterisk/voicemail/default/2653/tmp/gMfLqL format: wav49, 0xa03fca8
-- x=1, open writing:  /var/spool/asterisk/voicemail/default/2653/tmp/gMfLqL format: wav, 0x9fc9008
-- User ended message by pressing #
-- Playing 'auth-thankyou' (language 'en')
-- Executing Goto("Zap/17-1", "exit-SUCCESS|1") in new stack
-- Goto (macro-vm,exit-SUCCESS,1)
-- Executing Playback("Zap/17-1", "goodbye") in new stack
-- Playing 'goodbye' (language 'en')
-- Executing Hangup("Zap/17-1", "") in new stack
-- Hungup 'Zap/17-1'

And here’s an attempt to get to it:

Connected to Asterisk 1.2.12 currently running on asterisk1 (pid = 3649)
Verbosity is at least 5
Core debug is at least 1
– Executing Answer(“SIP/2653-0a041058”, “”) in new stack
– Executing Wait(“SIP/2653-0a041058”, “1”) in new stack
– Executing VoiceMailMain(“SIP/2653-0a041058”, “”) in new stack
– Playing ‘vm-login’ (language ‘en’)
– Playing ‘vm-password’ (language ‘en’)
– Executing Macro(“SIP/2653-0a041058”, “hangupcall”) in new stack
– Executing ResetCDR(“SIP/2653-0a041058”, “w”) in new stack
– Executing NoCDR(“SIP/2653-0a041058”, “”) in new stack
– Executing Wait(“SIP/2653-0a041058”, “5”) in new stack
– Executing Hangup(“SIP/2653-0a041058”, “”) in new stack
asterisk1*CLI>

No matter how I set the extension’s voicemail password via the FreePBX interface the password check appears to fail.

Does anyone have any suggestions please?

Sounds to me like its not receiving the dtmf properly – try
dtmf=inband and dtmfmode=inband for that extension or otherwise make
sure its getting there.

on Friday 10/13/2006 Cole([email protected]) wrote

–===============0804531691==

Among the other problems Ie,Ab€™e(Bm having getting our Asterisk/FreePBX system working, I cane,Ab€™e(Bt get at voice mail messages that have been left for a given extension.

Heree,Ab€™e(Bs the voicemail being saved:

-- Goto (macro-vm,s-DIRECTDIAL,1)
-- Executing NoOp("Zap/17-1", "DIRECTDIAL voicemail") in new stack
-- Executing Macro("Zap/17-1", "get-vmcontext|2653") in new stack
-- Executing Set("Zap/17-1", "VMCONTEXT=default") in new stack
-- Executing GotoIf("Zap/17-1", "0?200:300") in new stack
-- Goto (macro-get-vmcontext,s,300)
-- Executing NoOp("Zap/17-1", "") in new stack
-- Executing VoiceMail("Zap/17-1", "[email protected]|g(8)") in new stack
-- Playing 'vm-intro' (language 'en')
-- Playing 'beep' (language 'en')
-- Recording the message
-- x=0, open writing:  /var/spool/asterisk/voicemail/default/2653/tmp/gMfLqL format: wav49, 0xa03fca8
-- x=1, open writing:  /var/spool/asterisk/voicemail/default/2653/tmp/gMfLqL format: wav, 0x9fc9008
-- User ended message by pressing #
-- Playing 'auth-thankyou' (language 'en')
-- Executing Goto("Zap/17-1", "exit-SUCCESS|1") in new stack
-- Goto (macro-vm,exit-SUCCESS,1)
-- Executing Playback("Zap/17-1", "goodbye") in new stack
-- Playing 'goodbye' (language 'en')
-- Executing Hangup("Zap/17-1", "") in new stack
-- Hungup 'Zap/17-1'

And heree,Ab€™e(Bs an attempt to get to it:

Connected to Asterisk 1.2.12 currently running on asterisk1 (pid = 3649)
Verbosity is at least 5
Core debug is at least 1
– Executing Answer(“SIP/2653-0a041058”, “”) in new stack
– Executing Wait(“SIP/2653-0a041058”, “1”) in new stack
– Executing VoiceMailMain(“SIP/2653-0a041058”, “”) in new stack
– Playing ‘vm-login’ (language ‘en’)
– Playing ‘vm-password’ (language ‘en’)
– Executing Macro(“SIP/2653-0a041058”, “hangupcall”) in new stack
– Executing ResetCDR(“SIP/2653-0a041058”, “w”) in new stack
– Executing NoCDR(“SIP/2653-0a041058”, “”) in new stack
– Executing Wait(“SIP/2653-0a041058”, “5”) in new stack
– Executing Hangup(“SIP/2653-0a041058”, “”) in new stack
asterisk1*CLI>

No matter how I set the extensione,Ab€™e(Bs voicemail password via the FreePBX interface the password check appears to fail.

Does anyone have any suggestions please?

–===============0804531691==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline


Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
–===============0804531691==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users

–===============0804531691==–


Your life is like a penny. You’re going to lose it. The question is:
How do
you spend it?

     John Covici
     [email protected]

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users

Post generated using Mail2Forum (http://www.mail2forum.com)

Thanks John, but that doesn’t seem to be the problem. I’ve tried checking the voice mail for extension 2653 from some other extension and I get the same null response. Also, if I check the voice mail for extension 20 using extension 2653, it works just fine.

I next tried deleting extension 2653, then recreating it, but nothing appears to change. Is there a straightforward (i.e. cook book) way I can reset (i.e. blow away and recreate) everything having to do with voice mail?