VM BLF issues?

Ok so i have an interesting issue going on. Any time i send one of my extensions a voicemail, then use the aastra xml script on the phone to check the voicemail, you listen, then delete. So the issue is that when i check and delete the voicemail on the phone, the home screen of the phone will still she a little envelope and the BLF at the top will still flash. The only way i know to get it to go away is to do a am portal restart. It will clear immediately after that.
When i do a /var/www/html/aastra/utilities/check_install

i get the report
Aastra XML scripts 2.3.1 Installation Check

----------------------- Package installation -----------------------
Package php-gd … Passed
Package php-ldap … Passed
Package avahi … Passed
No Package mDNSResponder … Passed
No Package mDNSResponder-util … Passed
Phone firmware package ( … Passed
Package aastra-xml-scripts … Passed
Cache Directory (/var/cache/aastra/) … Passed
TFTP Directory (/tftpboot) … Passed
/tftpboot/aastra.cfg … Passed
php-agi connection … Passed
freePBX database connection … Passed
------------------ Asterisk/freePBX Configuration ------------------
Asterisk version (11.) … Passed
Asterisk location set to /etc/asterisk/ … Passed
Asterisk spooler set to /var/spool/asterisk/ … Passed
Voicemail configuration … FAILED
-> Please enable pollmailboxes in /etc/asterisk/voicemail.conf
-> Please configure USEDEVSTATE to True on /etc/amportal.conf
Wideband Codec (g722) configuration … WARNING
-> You may want to activate g722 in /etc/asterisk/sip_general_custom.conf or via the freePBX module
freePBX mode set to extensions … Passed
5 extension(s) configured … Passed
No meet-me room configured … WARNING
-> Please configure meet-me rooms using freePBX
Parking extension configured (70) … Passed
Intercom prefix configured (*80) … Passed
No day/night index configured … WARNING
-> Please configure day/night index using freePBX if you plan to use this function
No ACD queue configured … WARNING
-> Configure queues using freePBX interface
----------------- Aastra XML scripts Configuration -----------------
Debug mode not activated … Passed
Trace mode not activated … Passed
Language not forced … Passed
Asterisk SIP proxy forced to AA_PROXY_SERVER … Passed
Asterisk SIP registrar forced to AA_REGISTRAR_SERVER … Passed
Phone Signature check is enabled … Passed
Self-configuration admin password not configured … WARNING
-> You may want to configure it in config/asterisk.conf
Self-configuration user password not configured … WARNING
-> You may want to configure it in config/asterisk.conf for users without VM
Logout password check is enabled … Passed
Auto-Logout feature is enabled … Passed
Auto-Logout idle screen message is enabled … Passed
DND pauses all ACD queues disabled … Passed
Speed dial application enabled … Passed
Presence application enabled … Passed
Meet-me automatic launch enabled … Passed
Outgoing state display application enabled … Passed
Outgoing external lookup application disabled … Passed
Date/Time format (US) … Passed
User asked for timezone (no) … Passed
No hidden directory extension … Passed
Local dial plan … Passed
Country code: 1
Long distance prefix: 1
International prefix: 011
No outbound prefix
No local prefix
Local extension length not set

And yes i noticed the VM failure so i did as it says, still no difference?
#include vm_general.inc
#include vm_email.inc
302 => 302,WellFed General Mailbox,[email protected],attach=yes|saycid=no|envelope=no|delete=no


Any help would be great!

i do a amportal reload to fix this issue not restart. Not sure if it makes a difference.

sorry , no help can be given here , the aastra voicemail functionality is “illegal” and subject to penalties by anyone who uses it, so it can’t be supported by aastra nor FreePBX/Schmooze. (you can patch it to work in newer Asterii though if you read the code :slight_smile: )

In FreePBX, settings, voicemail admin, settings enable pollmailboxes and set a pollfreq to a reasonable number of seconds.

Will editing the config file manually through the CLI interfere with this?
It shows to be already set that way.
pollmailboxes toggle is yes

Try setting the freq to 5 sec. and see if the flag clears faster.

Awesome… Setting the Freq to 1 sec causes it to delete the voicemail flag the second you push the button!
I appreciate the help!

Be cautious. Excessive polling can cause the dilithium crystals in your CPU to breakdown earlier than expected.