Vitelity Outbound works, Inbound "Not In Service' message

Hello, I am new to the SIP World and am trying to fumble my way through a PIAF install at RentPBX using Vitelity as my SIP Provider. Everything has been going swimmingly up until I tried to dial in. I get the “Number is not in service” message. I changed my routing from my extension to “Terminate Call - Endless Hold Music” and low and behold I get stuck in endless hold music. I then switched back to my extension and I am back to the “Number is not in service” message.
I did some reading and one suggestion was to enable “Allow Anonymous Inbound SIP Calls” - but to no avail, still the “Number is not in service” message. I will post my CLI Output from an ssh session of my inbound call in hopes that someone can point me in the right direction.

== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Executing [[email protected]:1] Set(“SIP/vitel-inbound-00000007”, “__FROM_DID=8145060599”) in new stack
– Executing [[email protected]:2] NoOp(“SIP/vitel-inbound-00000007”, “Received an unknown call with DID set to 8145060599”) in new stack
– Executing [[email protected]:3] Goto(“SIP/vitel-inbound-00000007”, “s,a2”) in new stack
– Goto (from-trunk,s,2)
– Executing [[email protected]:2] Answer(“SIP/vitel-inbound-00000007”, “”) in new stack
– Executing [[email protected]:3] Wait(“SIP/vitel-inbound-00000007”, “2”) in new stack
– Executing [[email protected]:4] Playback(“SIP/vitel-inbound-00000007”, “ss-noservice”) in new stack
– <SIP/vitel-inbound-00000007> Playing ‘ss-noservice.gsm’ (language ‘en’)
– Executing [[email protected]:5] SayAlpha(“SIP/vitel-inbound-00000007”, “8145060599”) in new stack
– <SIP/vitel-inbound-00000007> Playing ‘digits/8.gsm’ (language ‘en’)
– <SIP/vitel-inbound-00000007> Playing ‘digits/1.gsm’ (language ‘en’)
– <SIP/vitel-inbound-00000007> Playing ‘digits/4.gsm’ (language ‘en’)
– <SIP/vitel-inbound-00000007> Playing ‘digits/5.gsm’ (language ‘en’)
– <SIP/vitel-inbound-00000007> Playing ‘digits/0.gsm’ (language ‘en’)
– <SIP/vitel-inbound-00000007> Playing ‘digits/6.gsm’ (language ‘en’)
– <SIP/vitel-inbound-00000007> Playing ‘digits/0.gsm’ (language ‘en’)
– <SIP/vitel-inbound-00000007> Playing ‘digits/5.gsm’ (language ‘en’)
– <SIP/vitel-inbound-00000007> Playing ‘digits/9.gsm’ (language ‘en’)
– <SIP/vitel-inbound-00000007> Playing ‘digits/9.gsm’ (language ‘en’)
– Executing [[email protected]:6] Hangup(“SIP/vitel-inbound-00000007”, “”) in new stack
== Spawn extension (from-trunk, s, 6) exited non-zero on ‘SIP/vitel-inbound-00000007’
– Executing [[email protected]:1] Macro(“SIP/vitel-inbound-00000007”, “hangupcall,”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/vitel-inbound-00000007”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] ExecIf(“SIP/vitel-inbound-00000007”, “0?Set(CDR(recordingfile)=)”) in new stack
– Executing [[email protected]:4] Hangup(“SIP/vitel-inbound-00000007”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘SIP/vitel-inbound-00000007’ in macro ‘hangupcall’
== Spawn extension (from-trunk, h, 1) exited non-zero on ‘SIP/vitel-inbound-00000007’

Do you have an inbound route 8145060599 ? You will need one, that is thwe intermediary step between an inbound call and an extension, did you read the wiki yet?

I do have an Inbound route for 8145060599. The destination for the route is Extension -> 201 (the only extension I have setup currently). Here are the details of that route:

Description?: Line 4
DID Number?: 8145060599
CallerID Number?: 8145060599
CID Priority Route?: [unchecked]
Alert Info?:
CID name prefix?:
Music On Hold?: Default
Signal RINGING?: [unchecked]
Pause Before Answer?:
Privacy Manager?: No
Source?: None
Call Recording?: Allow
Language?:
Destination: Extensions --> 201 Home

If I setup a catch all Incoming Route, the extension rings - not sure what the issue is. I used the DID that vitelity gave me 8145060599 in the DID field. I also tried adding a “1” before it and tried dropping the “814” - both to no avail

Well somehow this is all solved now. I removed my DID inbound route and recreated it only inputting the DID into the DID field and selecting the extension and saving… it now works. :slight_smile: