Virtual extensions not redirecting anymore?


(D E) #1

I have a bit of a feeling this I have a virtual extension, 4010, which used to just redirect to another (external) number when called. It did this using FMFM. Now it doesn’t, you just get a congestion error.

Initial ring time is 0 or 1 ( tried both )
Ring strategy is first available (have tried ringall, too)
Follow me list is the number I want to dial followed by #

Weirdly these used to work!

Even weirder one of them does, and it doesn’t seem to be setup any different to the others.

Call trace here and pic of FMFM here

THANKS!


(D E) #2

Interesting. I deleted then recreated the virtual extension, now in the log it says this…!
As I say, it used to work! I guess it broke during the upgrade from 14-15?

21329   [2020-11-21 15:36:49] VERBOSE[23834][C-000000a9] pbx.c: Executing [s@macro-dial-one:55] Dial("PJSIP/4002-000000bf", "VIRTUAL/4010,,Ttrb(func-apply-sipheaders^s^1)") in new stack	
21330	[2020-11-21 15:36:49] WARNING[23834][C-000000a9] channel.c: No channel type registered for 'VIRTUAL'	
21331	[2020-11-21 15:36:49] WARNING[23834][C-000000a9] app_dial.c: Unable to create channel of type 'VIRTUAL' (cause 66 - Channel not implemented)	
21332	[2020-11-21 15:36:49] VERBOSE[23834][C-000000a9] app_dial.c: No devices or endpoints to dial (technology/resource)	
21333	[2020-11-21 15:36:49] VERBOSE[23834][C-000000a9] pbx.c: Executing [s@macro-dial-one:56] ExecIf("PJSIP/4002-000000bf", "0?MacroExit()") in new stack

(Communication Technologies) #3

Is there an issue with PJSIP? You are calling VIRTUAL as a channel type and it is not finding it. what is labeled ‘VIRTUAL’ in your pbx?

Maybe the outbound route/trunk that is being used.